Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 10-23-2018, 06:26 PM
bobj bobj is offline
TT Newbie
 
Join Date: Sep 2015
Boat: Maristar 230 2003 5.7 tbi
Location: midwest
Posts: 7
tachometer/hour meter for 2003 Maristar 230

Tachometer on 2003 maristar is not working. Need help finding replacement. It is OEM and has BorgWarner 6502-08013-19 0-6000 RPM TACH 07/10/02 REV A on the sticker.
It has a 3" silver face, red needle indicator and digital hour meter.
Reply With Quote
  #2  
Old 10-23-2018, 08:38 PM
tommurtha tommurtha is offline
MC Fanatic
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: South Windsor, CT & Richmond Ma
Posts: 807
borg warner??? I thought they all were Medallion
Reply With Quote
  #3  
Old 10-23-2018, 09:22 PM
lakedrum03's Avatar
lakedrum03 lakedrum03 is offline
MC Fanatic
 
Join Date: Jul 2017
Boat: 2003 X-Series MCX
Location: Ohio
Posts: 680
Quote:
Originally Posted by tommurtha View Post
borg warner??? I thought they all were Medallion
Thatís what I thought too.
__________________
Being on a boat that's moving through the water, it's so clear. Everything falls into place in terms of what's important and what's not. - James Taylor
Reply With Quote
  #4  
Old 01-09-2019, 02:52 PM
bobj bobj is offline
TT Newbie
 
Join Date: Sep 2015
Boat: Maristar 230 2003 5.7 tbi
Location: midwest
Posts: 7
Tach/hourmeter

Still searching for this OEM Gauge. Can't find any supplier or anyone to repair. This was OEM supplied on 2003 Mairstar 230 5.7 EFI Indmar. Any contacts or info appreaciated.
Reply With Quote
  #5  
Old 01-09-2019, 03:03 PM
tommurtha tommurtha is offline
MC Fanatic
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: South Windsor, CT & Richmond Ma
Posts: 807
I think you might need to verify Borg Warner, my 2003 is all medallion and those look like medallion numbers.. have you called them?
Reply With Quote
  #6  
Old 01-14-2019, 11:12 AM
DanMahx DanMahx is offline
TT Regular
 
Join Date: Aug 2006
Boat: 1991 Prostar, 2003 Maristar 210
Location: Southeast
Posts: 42
If you still have the Medalion system it might not be the gauge but something else - most likely a bad ground somewhere.
Reply With Quote
  #7  
Old 01-16-2019, 03:01 PM
bobj bobj is offline
TT Newbie
 
Join Date: Sep 2015
Boat: Maristar 230 2003 5.7 tbi
Location: midwest
Posts: 7
Have sent emails w/o success. Do you have any contact numbers?
Reply With Quote
  #8  
Old 01-16-2019, 03:03 PM
bobj bobj is offline
TT Newbie
 
Join Date: Sep 2015
Boat: Maristar 230 2003 5.7 tbi
Location: midwest
Posts: 7
Have checked grounds and distributer connections. Everything appears good.
Reply With Quote
  #9  
Old 01-16-2019, 05:57 PM
tommurtha tommurtha is offline
MC Fanatic
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: South Windsor, CT & Richmond Ma
Posts: 807
Quote:
Originally Posted by bobj View Post
Have sent emails w/o success. Do you have any contact numbers?
I have contacts for Medallion. have you confirmed you have Medallion gauges..
Reply With Quote
  #10  
Old 01-17-2019, 12:12 PM
Fullpass's Avatar
Fullpass Fullpass is offline
MC Fanatic
 
Join Date: Dec 2013
Boat: MasterCraft 197 Pro Tournament Team
Location: Northern Midwest
Posts: 833
Send a message via Yahoo to Fullpass
I've seen some labels on 2003 gauges...that read Borg Warner
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:05 AM.


2018