PDA

View Full Version : 2007 X-Star Redemption


CRUSH
08-27-2018, 04:50 PM
This will be a long first post about the New to me XStar that I am sure some of you will remember. I ended up buying this X-Star over Memorial Day weekend 2018.

http://www.mastercraft.com/teamtalk/showthread.php?t=70914&highlight=2007+star

Needless to say it needed some work and there were some cooling issues with the closed-loop system and we thought it needed new heads. Try to do it myself...fail. Took it to a mechanic and it looks as if the wrist pin on the number 2 cylinder is coming lose. So we go with option number 2 a brand new 0 time engine. This takes all summer and we finally got the boat back 5 days ago.

We've made the most of the last week and are planning a Lake Wylie trip to meet up with some friends for Labor Day Weekend. Pics Below. With more details.

Consider this my official X-Star rebuild thread where I'll probably be asking for help in the future.

Cheers!

CRUSH
08-27-2018, 04:53 PM
New ZERO time Engine; New exhaust manifolds, all new cooling piping. Looking Good!

CRUSH
08-27-2018, 05:02 PM
While we were waiting for the Engine to get done I took care of the entire speaker system.

M606 Receiver
M600/1 Subwoofer for the Sub
M400/4 for the Tower Spekers
M600/6 for the Inboard speakers
Also got a new remote for the driver and XM squared away.

Everything is woking except a squeal on one of the inboard channels, and we are troubling shooting that now.

Tower speakers were all sourced from eBay or this site (thanks for the help) inboard speakers all worked.

Lights do not work but I think it is a master console issue, since the only thing that works on it is the Tac and the pumps.

Pics below.

CRUSH
08-27-2018, 05:05 PM
Gator Step was the next project that we got done this week. Straightforward and simple install, just make sure the surface is clean prior. The look totally changes the boat.

John Johnson
08-27-2018, 05:09 PM
Beautiful! Nice work! No stress with the motor now. New boat.

CRUSH
08-27-2018, 05:09 PM
And now some Boat porn after a fun weekend on the Chesapeake!

CRUSH
08-27-2018, 05:11 PM
The project today was Ballast Pumps.

The pumps work and the lines are all clear it seems as if the timers may have an issue. Going to ops test it in the water tonight and see what we get. Will probably have questions tomorrow.

CRUSH
08-27-2018, 07:26 PM
Just got off the water. Ballast pump timers are not working properly. Everything turns on for about 5 seconds and then shuts off automatically. Gonna check the Ballast forum for some answers, but does anyone have some initial feedback for the ballast pumps. Thanks.

lukedeuce
08-27-2018, 07:32 PM
How do you like the m606 head unit? I’ve been looking around at replacements for my xmd1 that has Bluetooth. A couple reviews I have read said not good compatibility with iOS devices

rgardjr1
08-27-2018, 07:47 PM
Just got off the water. Ballast pump timers are not working properly. Everything turns on for about 5 seconds and then shuts off automatically. Gonna check the Ballast forum for some answers, but does anyone have some initial feedback for the ballast pumps. Thanks.

Make sure your bilge pumps are working. Both of mine were dead on my SS boat when I bought it after two years.


A couple reviews I have read said not good compatibility with iOS devices

I just posted my review of the M608 on Amazon last night. It does not support playlists though a USB connection with my Iphone 7. I talked to Clarion and they confirmed that it does not and will not support playlists. Pretty much makes it useless for me to try and control the music through my drivers remote. I had a CMD6 that was working perfectly with an old Ipod touch before I swapped it out. The scrolling text on the remotes is a nice improvement with the M608, but I already had the multizone taken care of so I didn't need that feature.

lukedeuce
08-27-2018, 08:02 PM
I just posted my review of the M608 on Amazon last night. It does not support playlists though a USB connection with my Iphone 7. I talked to Clarion and they confirmed that it does not and will not support playlists. Pretty much makes it useless for me to try and control the music through my drivers remote. I had a CMD6 that was working perfectly with an old Ipod touch before I swapped it out. The scrolling text on the remotes is a nice improvement with the M608, but I already had the multizone taken care of so I didn't need that feature.

Head unit is on my side, no remote. Not too concerned with multi zone, but if I go that route then it may be time to do an overhaul on everything

CRUSH
08-27-2018, 08:33 PM
Sorry; it's an M608 I like it. Multi zone control is nice when I don't need the tower speakers on. I Bluetooth to it but occasionally I need to forget the current 608 and rediscover the radio again to connect. Overall nice product.

Mastar
08-27-2018, 11:40 PM
you should reprogram the ballast timers, just search ballast timers reprogram.
He has a website too wakeblasters or something its legit and worth it

CRUSH
08-29-2018, 11:38 PM
Teak Reconditined and looking way better; engine dividers complete and installed; boats ready for the weekend.

CRUSH
10-25-2018, 08:48 AM
Took advantage of the full moon last night. Here are some unedited shots of the boat and the truck unintentionally in the back. Waters hovering around mid 60s but the air temp was in the 50s last night in Hampton, VA.

CottagerGreg
10-25-2018, 10:04 AM
Looking good, an off season cut and polish on the hull and it will look like a new boat!

Mastar
10-25-2018, 10:11 AM
Looks good, are you going to put any decals on it? I think it would look good with a chrome or black Mastercraft on the rear and an X STAR centered on each side. I installed seadek similar to your gator step.

JTNG
10-25-2018, 10:49 AM
That looks like a photo to enlarge and hang in your man cave!!

Malek779
10-25-2018, 04:32 PM
what did it cost for the whole gator setup?

Upnorth07
10-25-2018, 05:05 PM
Great work and congrats on your Xstar!

cwarndahl
10-26-2018, 12:08 AM
Nice! Your gonna have a looooong winter!


Sent from my iPhone using Tapatalk

tr6coug
10-26-2018, 01:40 AM
Just got off the water. Ballast pump timers are not working properly. Everything turns on for about 5 seconds and then shuts off automatically. Gonna check the Ballast forum for some answers, but does anyone have some initial feedback for the ballast pumps. Thanks.

I can fix them for you. PM me if you're interested.

Link to thread about them.
https://www.mastercraft.com/teamtalk/showthread.php?t=50038