PDA

View Full Version : ballast tank gauge accuracy??


h2oskiluvr
06-01-2014, 09:41 PM
I have a 2013 x14v I purchased towards the end of last summer. The first computer stopped working and they put in a new one in the fall when the boat was winterized. I've only been out a few times and already I am getting major funky readings on the ballast tank readings.

I will fill them up (overflow) and the readings for all three will be 100%. I turn the boat off/on and now the center take reading is 50%. I empty all the tanks and turn the boat off/on and now the right side tank is 100% full.

Basically I never know if they are completely full or completely empty when I need them to be based on the gauges alone. Should I have any expectation that the readings be accurate?

bturner2
06-02-2014, 07:20 AM
Boat gas and ballast gauges are notoriously inaccurate. Yours seem to be effected by a bad ground or bad sensor. As you're still under warranty I would start a service list and once you get to the pain versus use point take it in and have them fix it.

I've changed sensors and tuned mine several times only to have them stop being accurate just a couple weeks later. Basically got them to be consistent and left them there. With a new boat and warranty..... I'd have them fixed every time the boat went in for service until the warranty went out.

bcd
06-02-2014, 11:37 AM
2012 didn't have sensors. It was all based on the computer calculating the level based on time, current flow, etc (not sure exactly what all it used and heard different answers from different people). Have you verified that you have the latest software? There were a lot bugs early on, but the latest version is supposed to resolve a lot of them.

Sent from my DROID RAZR HD using Tapatalk

rtw_travel
06-02-2014, 01:38 PM
2013 used Murphy controls, but I think the tank level logic is the same as the 2012 medallion controls: they calculate tank level based on pump operation time rather than an actual tank gauge. i.e. if it takes 3 minutes to empty the tank, and the pump has been on for 1.5 minutes, then the gauge will show the tank to be half full. I believe Murphy allows calibration by users in one of its setup screens, but I haven't taken delivery of my boat yet to verify.

I have not heard of the gauges changing levels when you turn them off/on - that seems to be a different problem than just timers. Definitely let the dealer know there is an issue.

bcd
06-02-2014, 03:57 PM
Sorry, I misread 2012 instead of 2013.

Sent from my DROID RAZR HD using Tapatalk

h2oskiluvr
06-02-2014, 08:43 PM
Thanks for input everyone! I am going to call the dealer and get this checked out. I believe this model is based on pump revolutions but that doesn't explain why they "jump" up and down.

blackhawk
06-02-2014, 09:53 PM
My 2006 gauges are pretty much useless. We sent a man to the moon in 1969 with the computing power of a modern calculator, but Mastercraft can't make a reliable system to tell us how much water is in a plastic tank, 40 years later.

Do other boat brands have similar problems?

h2oskiluvr
06-02-2014, 09:56 PM
My 2006 gauges are pretty much useless. We sent a man to the moon in 1969 with the computing power of a modern calculator, but Mastercraft can't make a reliable system to tell us how much water is in a plastic tank, 40 years later.

Do other boat brands have similar problems?

Funny, and so true!