PDA

View Full Version : Just bought a 1983 S&S......


the natural
05-27-2014, 05:59 PM
I purchased a 1983 S&S this past fri. Took it out and someone ride along that knows boats and motors. Everything went well for being 31 yes old. It hr meter says 1100. But I believe it's actually lower.... its brown and white.

the natural
05-27-2014, 06:03 PM
http://i225.photobucket.com/albums/dd295/twalter30/Mobile%20Uploads/IMG951967.jpg (http://s225.photobucket.com/user/twalter30/media/Mobile%20Uploads/IMG951967.jpg.html)

the natural
05-27-2014, 06:05 PM
http://i225.photobucket.com/albums/dd295/twalter30/Mobile%20Uploads/IMG957898.jpg (http://s225.photobucket.com/user/twalter30/media/Mobile%20Uploads/IMG957898.jpg.html)

the natural
05-27-2014, 06:05 PM
http://i225.photobucket.com/albums/dd295/twalter30/Mobile%20Uploads/IMG954083.jpg (http://s225.photobucket.com/user/twalter30/media/Mobile%20Uploads/IMG954083.jpg.html)

the natural
05-27-2014, 06:07 PM
http://i225.photobucket.com/albums/dd295/twalter30/Mobile%20Uploads/20140522_215043.jpg (http://s225.photobucket.com/user/twalter30/media/Mobile%20Uploads/20140522_215043.jpg.html)

pmkkdx
05-27-2014, 06:47 PM
Congrats!

the natural
05-27-2014, 06:52 PM
http://i225.photobucket.com/albums/dd295/twalter30/Mobile%20Uploads/20140523_202339.jpg (http://s225.photobucket.com/user/twalter30/media/Mobile%20Uploads/20140523_202339.jpg.html)

the natural
05-27-2014, 06:54 PM
Other than cleaning on fri. I had to redo the teak platform. ...

the natural
05-27-2014, 06:54 PM
http://i225.photobucket.com/albums/dd295/twalter30/Mobile%20Uploads/20140525_145918.jpg (http://s225.photobucket.com/user/twalter30/media/Mobile%20Uploads/20140525_145918.jpg.html)

the natural
05-27-2014, 07:04 PM
I had a little ordeal fri when we took it out. Rode for about 25 min cut switch off no prob. Started it back up drove 45 mine. Tried to turn switch off. Nothing it continued to run I wiggled a few wires it cut off. Thought It was the switch, after doing this again on sat I started looking around. If I left the battery connect the hr meter continued to run. I could hear it tick. Even with switch off, dash lights would stay on also. I pulled the lower panel off and found 2 wires melted together Pulled them apart retaped them. And been working great ever since. I just wander how many hrs are really on this boat.

the natural
05-27-2014, 08:05 PM
I do have a question. I have alot of rust on the piece of channel that is (lag screws) bolted to the fiberglass stringer in the motor compartment. It will need to be replaced. I have searched for the part name. But can't find it

waterlogged882
05-27-2014, 08:09 PM
..........

Spork
05-27-2014, 08:12 PM
I purchased a 1983 S&S this past fri. Took it out and someone ride along that knows boats and motors. Everything went well for being 31 yes old. It hr meter says 1100. But I believe it's actually lower.... its brown and white.

Nice root beer and cream

the natural
05-27-2014, 08:18 PM
Thanks J. Is it a motor mount?

Spork
05-27-2014, 08:21 PM
Thanks J. Is it a motor mount?

I think what your looking for is just a piece of angle iron with the mount bracket welded on and that connects to the engine mount, you might just use a local welder to duplicate whats there I don't think you find one for sale.

http://www.skidim.com/ has lots of parts for older inboards but a bit pricey, use them for research but buy else where...

the natural
05-27-2014, 08:22 PM
Ok. Thanks...

Xjet2011
05-27-2014, 08:23 PM
Nice boat. Enjoy. I'm sure you will have a great summer.

orbeamlb
05-27-2014, 08:51 PM
Congrats! Have fun with it.

thatsmrmastercraft
05-27-2014, 09:15 PM
I had a little ordeal fri when we took it out. Rode for about 25 min cut switch off no prob. Started it back up drove 45 mine. Tried to turn switch off. Nothing it continued to run I wiggled a few wires it cut off. Thought It was the switch, after doing this again on sat I started looking around. If I left the battery connect the hr meter continued to run. I could hear it tick. Even with switch off, dash lights would stay on also. I pulled the lower panel off and found 2 wires melted together Pulled them apart retaped them. And been working great ever since. I just wander how many hrs are really on this boat.

Nice job finding the problem. Using a piece of shrink-wrap instead of tape makes for a much more permanent solution. If you want to go all in, solder the terminal to the wire, then shrink wrap it.

Great looking boat :toast:

the natural
05-27-2014, 09:34 PM
I have alot of plans for it. Next is to get the oxidation off the hull, have been reading and researching. Interior is bad, but will do it during winter.

thatsmrmastercraft
05-27-2014, 09:36 PM
The nice thing about having one of these boats is they take care of all your spare free time and money.:rolleyes:

SSMoose
05-27-2014, 10:13 PM
The nice thing about having one of these boats is they take care of all your spare free time and money.:rolleyes:

That's for sure, Peter. On the other hand, the time and money has to be dealt with one way or another!
:cool:

the natural
05-28-2014, 12:03 PM
Very true fellas.


I need to get exhaust flaps. I've looked at Overtons. Is 24.99/each about what they run or is there somewhere else I can look. I saw some on ebay for less than $5. Didn't know if they would last...