PDA

View Full Version : Partially deployed tab


skitilldark
05-25-2014, 04:26 PM
I saw the other thread on this from the X30 where the prop wash was going wonky. I have been trying for two days to dial in a good crisp, even wake and cannot do it. I finally realized that I have a surf tab on the driver's side that is deployed further than the one on the passenger side. You can tell pretty easily as the one on the passenger's side tucks right up against the platfomr bracket, but the one on the right is about 3 or 4 inches down. This is just far enough to catch the flow coming off the hull and kick it up in the air. The result is that it curves the top of the drivers side wake inward instead of developing a lip. I've tried everything in the software to figure it out. according to the computer everything is retracted 100% but you can tell just by looking that the driver's tab is NOT fully retracted. Does anyone have any ideas I could try?

Quinten
05-26-2014, 01:00 PM
It looks like the piston if fully in.

Did you check the mounting holes of the piston is about the same place?

ap77
05-26-2014, 05:54 PM
I was out on a 2014 X25 for a test drive with the dealer a few weeks ago and the same issue happened. Basically the driver side surf tab kept deploying. I'll have to ask them what they did to fix it.

jeff.leitheiser
06-03-2014, 07:25 PM
I have a 2012 X25 and my surf tabs are acting up as well. For me, they'd deploy to get on plane but when center tab came up the other two stayed down. Then when i was leaving for the day the computer said all tabs are up and after trailoring I noticed the driver side didn't come up all the way. Dealer told me they recently did a firmware update on mine and its back at the dealer getting worked on. Awesome!

dt37803
06-03-2014, 09:03 PM
My X2tab on the driver side stays down slightly, maybe an inch or two when I loaded up on the trailer also. I will inquire on Monday when we take it in for the 25 hour service. (25 hours in only 5 incredible outings) Absolutely love the X2 :)

ap77
06-03-2014, 09:11 PM
Is it just me or are others also not thrilled with all the software automation on newer boats? I am a computer nerd and love software in general, but software isn't 100% reliable so I would prefer less automation. I'll take toggle switches that work every time over glitchy computer automation.

jeff.leitheiser
06-03-2014, 10:55 PM
I love the automation when it works, when it doesn't it just pisses you off. I think when you buy a 100K dollar boat the automation should be flawless! Kinda frustrating and taking away from my lake time...

skitilldark
06-04-2014, 07:26 AM
I love the automation when it works, when it doesn't it just pisses you off. I think when you buy a 100K dollar boat the automation should be flawless! Kinda frustrating and taking away from my lake time...

Amen on that. I even have had the touch screen quit working(3 times). I have to power down the boat and kill the battery to get it back working. About those tabs, I have since realized you just have to bump the manual tab buttons to get them to fully retract, but I agree...100k and they can't figure out how to get the software to do that?

jeff.leitheiser
06-04-2014, 11:16 AM
Yeah, I've had issues every year with the boat. One year all 3 tabs went full down and nothing i did would get them to come up. finally limped back to the dock and while heading to the truck to get the trailer with the boat off they all just came up... It was explained to me that is a safety feature with the boat off and battery power still on after a certain amount of time they should all come back up but nothing ever explained the random all 3 down with absolutely no way to get them back up. Issue didn't happen again that year so never took it in. With this latest issue i'm guessing its their new firmware they put in this summer and I don't mind being the guy who gives it back and tells them to fix it for all of us... or maybe they'll just give me a new boat with Gen2 :)