Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-16-2014, 07:35 AM
kc1 kc1 is offline
TT Newbie
 
Join Date: Aug 2014
Boat: mastercraft, prostar 205, 1999, indmar
Location: midatantic
Posts: 15
idle only no power

At end last season all well. Winterized and now just waking back up. Starts well and engine sounds good. But when given throttle in forward or reverse no additional powe?
Reply With Quote
  #2  
Old 08-16-2014, 07:38 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,360
Does the engine rev up but the boat doesn't move?
__________________
Tim
Gone, surfing.
Reply With Quote
  #3  
Old 08-16-2014, 07:42 AM
kc1 kc1 is offline
TT Newbie
 
Join Date: Aug 2014
Boat: mastercraft, prostar 205, 1999, indmar
Location: midatantic
Posts: 15
No rev. Boat moves but with limited power and rpm.
Reply With Quote
  #4  
Old 08-16-2014, 11:12 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 11,124
Send a message via Skype™ to mikeg205
1999 - fuel pump in tank?
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #5  
Old 08-16-2014, 11:27 AM
kc1 kc1 is offline
TT Newbie
 
Join Date: Aug 2014
Boat: mastercraft, prostar 205, 1999, indmar
Location: midatantic
Posts: 15
Not sure . Repowered a year ago with a crate indmar engine kit..
Reply With Quote
  #6  
Old 08-16-2014, 11:36 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 11,124
Send a message via Skype™ to mikeg205
if pump in tank... looks like this...
Attached Images
 
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #7  
Old 08-16-2014, 11:37 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 11,124
Send a message via Skype™ to mikeg205
If it's external it will look similar to this...
Attached Images
 
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #8  
Old 08-16-2014, 11:39 AM
ap77's Avatar
ap77 ap77 is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: Mastercraft X2 2009 MCX
Location: Northwest
Posts: 258
I had a similar issue after winterization (boat wouldn't get over 2000 RPM's). I reset the Perfect Pass and problem went away.
__________________
Andrew
Reply With Quote
  #9  
Old 08-16-2014, 11:40 AM
kc1 kc1 is offline
TT Newbie
 
Join Date: Aug 2014
Boat: mastercraft, prostar 205, 1999, indmar
Location: midatantic
Posts: 15
Thanks - I will check out now.
Reply With Quote
  #10  
Old 08-16-2014, 01:46 PM
kc1 kc1 is offline
TT Newbie
 
Join Date: Aug 2014
Boat: mastercraft, prostar 205, 1999, indmar
Location: midatantic
Posts: 15
Fuel Pump

Appear to be an external fuel pump check out photo
Attached Images
    
Reply With Quote
Reply

Tags
limited power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:52 AM.