Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 07-06-2014, 06:49 PM
rek's Avatar
rek rek is offline
TT Enthusiast
 
Join Date: Nov 2013
Boat: Mastercraft X9 - 2003
Location: Southeast
Posts: 100
2003 Fix original bag ports? (pics)

Factory ballast bags on my X9 are leaking badly at the entry/exit ports. As you can see from the pics, the adhesive between the ports and the bag are shot. I pulled the ports out and tried to re-apply adhesive but can't get them to stick/not leak. They just pull right off again. Not sure if it's my technique or the adhesive i'm using. Tried two types of adhesive from Home Depot that you mix together. (loc tight, etc) Also, rubber cement i read on another thread. Still doesn't fix the problem. Leaky at best or pull right off again.

Any suggestions? I'm going to get new bags eventually but would like to fix the center locker and under the rear seat bag to possibly use somewhere else on the boat later on. Please advise! thx.
Attached Images
  
__________________
Mastercraft X9 MCX (2014-Now)
Four Winns H180 (2008 - 2014)
Reply With Quote
  #2  
Old 07-08-2014, 10:19 AM
JRW160's Avatar
JRW160 JRW160 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: 2003 X2
Location: Huntsville, AL
Posts: 1,302
I used PL construction adhesive to repair the same problem with mine, and it has held up for 3 years.
http://www.loctiteproducts.com/p/12/...n-Adhesive.htm
Reply With Quote
  #3  
Old 07-08-2014, 10:49 AM
02ProstarSammyD 02ProstarSammyD is offline
TT Regular
 
Join Date: Apr 2011
Boat: 2002 Prostar 209 - SammyD Edition
Location: Southeast
Posts: 1,900
If I still have it I'll ship you a free under seat bag. Its old and ugly but worked when I pulled it out. Just pay processing and handling. Will check tonight.
Reply With Quote
  #4  
Old 07-08-2014, 03:50 PM
soacj's Avatar
soacj soacj is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: Current: '03 X2 w/ MCX. Former: '91 Prostar
Location: Virginia
Posts: 531
Quote:
Originally Posted by JRW160 View Post
I used PL construction adhesive to repair the same problem with mine, and it has held up for 3 years.
http://www.loctiteproducts.com/p/12/...n-Adhesive.htm
I repaired a split in my KGB fitting with this same adhesive based on JRW160's endorsement. It's holding great--I had thought the bag was a goner for sure. I found the adhesive in stock at Home Depot.
Reply With Quote
  #5  
Old 07-08-2014, 06:12 PM
rek's Avatar
rek rek is offline
TT Enthusiast
 
Join Date: Nov 2013
Boat: Mastercraft X9 - 2003
Location: Southeast
Posts: 100
Thanks for the suggestions guys. I'll try the PL construction adhesive and report back!

02ProstarSammyD, about to send you a PM thanks for offering man! Love this forum.
__________________
Mastercraft X9 MCX (2014-Now)
Four Winns H180 (2008 - 2014)
Reply With Quote
  #6  
Old 07-13-2014, 07:35 PM
JRW160's Avatar
JRW160 JRW160 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: 2003 X2
Location: Huntsville, AL
Posts: 1,302
Quote:
Originally Posted by soacj View Post
I repaired a split in my KGB fitting with this same adhesive based on JRW160's endorsement. It's holding great--I had thought the bag was a goner for sure. I found the adhesive in stock at Home Depot.
Glad it worked out. After a $450 quote I got for a new bag, I was ready to try anything.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:26 PM.