Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #11  
Old 03-15-2014, 07:11 AM
pimp800 pimp800 is offline
TT Regular
 
Join Date: Jan 2014
Boat: soon to be owner
Location: Georgia
Posts: 50
Hey thanks mark. I will give that a try this morning when I get back out there.
Reply With Quote
  #12  
Old 03-15-2014, 07:29 AM
davidstan's Avatar
davidstan davidstan is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: 2008 X2
Location: AL/GA
Posts: 579
I have the 08 vdig and it sometimes just needs to be reset. Turn your perko on and off after 3 minutes also. The vdig has some gremlin going on on rare occasion.
__________________
David
2008 X2 MCX
1999 Maristar 210 (sold)
1996 Bayliner 2050
Reply With Quote
  #13  
Old 03-15-2014, 07:42 AM
pimp800 pimp800 is offline
TT Regular
 
Join Date: Jan 2014
Boat: soon to be owner
Location: Georgia
Posts: 50
Thanks davidstan. Can you be more specific on what your are talking about. I've cycled the switch several times. Am I missing something?
Reply With Quote
  #14  
Old 03-15-2014, 09:30 AM
pimp800 pimp800 is offline
TT Regular
 
Join Date: Jan 2014
Boat: soon to be owner
Location: Georgia
Posts: 50
reset the kill switch and started working, thanks guys
Reply With Quote
  #15  
Old 03-15-2014, 09:44 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is online now
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 14,888
The kill switch has been the source of many headaches.
__________________
Peter

Tandem Axle Wheel & Tire Package $659
4 S5 or S5 Black 14x5.5 wheels, 4 ST205/75R14 Kenda Loadstar tires

Single Axle Wheel & Tire Package $399
2 S5 or S5 Black 14x5.5 wheels, 2 ST205/75R14 Kenda Loadstar tires
MOUNT, BALANCE & FREE SHIPPING INCLUDED IN BOTH PACKAGES



CARB REBUILDING - FAST TURN-AROUND - $125 +PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts - Red, Blue & Black


PM or email me tiresplease@gmail.com
Reply With Quote
  #16  
Old 03-15-2014, 10:46 AM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Fanatic
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Kansas City
Posts: 668
My kill switch is by passed... I know, safety switch is there for a reason. I've NEVER even considered clipping the little red cord to me while operating.
Welcome and congrats on the XStar!!
__________________
Screws fall out all the time, the world is an imperfect place.
Reply With Quote
  #17  
Old 03-15-2014, 10:56 AM
Theclarks1111's Avatar
Theclarks1111 Theclarks1111 is offline
TT Enthusiast
 
Join Date: Jun 2011
Boat: 2007 X2
Location: Southeast
Posts: 210
Quote:
Originally Posted by neil.anderson63 View Post
My kill switch is by passed... I know, safety switch is there for a reason. I've NEVER even considered clipping the little red cord to me while operating.
Welcome and congrats on the XStar!!
Do you have the analog gauges on your 07 X2? Just curious why you bypassed the kill switch, is it because it was causing a problem? I have an 07 X2 with analog gauges and everytime I turn my boat off from running, straight over to the acc to keep the stereo on, I get an alarm. I have to wait for about 2 minutes and then it can go to acc.
Reply With Quote
  #18  
Old 03-15-2014, 11:16 AM
MattsCraft's Avatar
MattsCraft MattsCraft is offline
MC Devotee
 
Join Date: May 2008
Boat: 2013 X25 - 6.2 Ilmor Baby
Location: Cincinnati, OH
Posts: 1,077
One other thing on your VDIG - Make sure you disable/turn off the start up video, it will cause problems. Sorry, can't remember exactly how to do it, but if you search here you will find it.

Search VDIG
Reply With Quote
  #19  
Old 03-18-2014, 01:29 PM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Fanatic
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Kansas City
Posts: 668
Quote:
Originally Posted by Theclarks1111 View Post
Do you have the analog gauges on your 07 X2? Just curious why you bypassed the kill switch, is it because it was causing a problem? I have an 07 X2 with analog gauges and everytime I turn my boat off from running, straight over to the acc to keep the stereo on, I get an alarm. I have to wait for about 2 minutes and then it can go to acc.
Yes, I have analog gauges. I didn't have any trouble with electrical or an alarm sounding. I would occasionally get something snagged on the tether and boat would kill, or not start. So I bypassed the switch.
__________________
Screws fall out all the time, the world is an imperfect place.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:14 AM.