Go Back   TeamTalk > Off Topic > Off Topic Discussion

Reply
 
Thread Tools Display Modes
  #21  
Old 10-17-2013, 11:55 PM
ProStar190Fan's Avatar
ProStar190Fan ProStar190Fan is offline
TT Enthusiast
 
Join Date: May 2008
Boat: MasterCraft, ProStar 190, 1988, Ford 351 240hp
Location: Grand Forks
Posts: 286
Pulled the trigger on Goodyear All Terrain Adventures with Kevlar. I was able to get in touch with a few people who have these already on the 3/4 ton suburbans and they had great things to say. They are getting installed on Tuesday.

Thanks everyone
__________________
Tom

1988 ProStar 190 red/gray
-Ford 351
-OJ 13x11 prop
-Kenwood Stereo

Need a manual go here http://www.mastercraft.com/knowledge/owners_manuals/
Reply With Quote
  #22  
Old 10-29-2013, 11:12 PM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,734
Just to add to the mix for future reference.

Hankook Dynapro Atm
Cooper Discovery AT3
Toyo Open Country AT


I had issues with my BFG's as well with balancing. The also chuck rocks like crazy. Also had a pair if Nitto Terra Grapplers that didn't wear well at all.
__________________
2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop.
Reply With Quote
  #23  
Old 10-30-2013, 12:01 AM
Aric'sX15's Avatar
Aric'sX15 Aric'sX15 is online now
MC Maniac
 
Join Date: Nov 2007
Boat: 85' S&S
Location: DFDUB
Posts: 4,154
swat what kind of truck do you drive? i put 15k on terras before i sold my silverado and they showed no wear at all!

funny you recommend togo at's and they are the same company and tread pattern as terras! haha
__________________
"if one day the speed kills me, do not cry because i was smiling." -Paul Walker
Reply With Quote
  #24  
Old 10-30-2013, 01:13 PM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,734
They were on A Yukon XL that had about 22k. I rotate them on schedule. Maybe it was the crap city streets, but the wear pattern was awful They were very smooth til about 17k. They would chatter like crazy on the highway.


The Toyo Open Country was way more quiet and way mor smooth on highway and through the fine Chicago streets. Way less jarring. I had both of these on the same Yukon XL. The Toyo's second. I run Nitrogen so the pressure stays very even. Run the 285/70/17. The Toyo performed so much better it's probably the smoothest and most quiet AT tire I have had. Owned 4 sets. Maybe bad set of Nittos?

I wanted to change it up a bit so decided to give Hankook try on a recommendation from some buddies who swear by them for actual off road and farm type stuff in the snow and what not. So far 37k on them they are still smooth. Little louder, but they have bit more bite n traction in the snow than the Toyo from my experience.
__________________
2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop.

Last edited by swatguy; 10-30-2013 at 02:14 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:31 PM.