Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 10-03-2013, 06:50 PM
MattsCraft's Avatar
MattsCraft MattsCraft is offline
MC Devotee
 
Join Date: May 2008
Boat: 2013 X25 - 6.2 Ilmor Baby
Location: Cincinnati, OH
Posts: 1,084
I never remove the rear plug, really has no purpose except if you drain the oil from the drain hose.

All the water is in the front bilge on an inboard.

Switching from an I/O to an inboard is like having a new pair of underwater, at first it is constricting, but then it becomes a part of you.

Welcome to the way boating was meant to be. Inboard forever, I/O never


Sent from my iPhone using Tapatalk
Reply With Quote
  #12  
Old 10-03-2013, 07:59 PM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,710
Quote:
Originally Posted by MattsCraft View Post
I never remove the rear plug, really has no purpose except if you drain the oil from the drain hose.

All the water is in the front bilge on an inboard.

Switching from an I/O to an inboard is like having a new pair of underwater, at first it is constricting, but then it becomes a part of you.

Welcome to the way boating was meant to be. Inboard forever, I/O never


Sent from my iPhone using Tapatalk
matt, a new pair of underwater? what's that, tracking fins!

agree nothing every comes out of the back plug area.
Reply With Quote
  #13  
Old 10-03-2013, 08:48 PM
uplander uplander is offline
MC Fanatic
 
Join Date: Jan 2013
Boat: MC 2002 X30
Location: midwest
Posts: 658
my back plug is stuck in, tried several times

one thing put your bilge pump on auto, there should be a toggle switch for bilge that has auto/man switch it to auto. Saved me once when the ballast broke open
Reply With Quote
  #14  
Old 10-03-2013, 10:32 PM
Traxx822's Avatar
Traxx822 Traxx822 is offline
MC Devotee
 
Join Date: Jul 2012
Boat: Mastercraft, Maristar 200VRS, 1995, Indimar 5.7, My first MasterCraft
Location: Chicago SW sub
Posts: 2,484
Quote:
Originally Posted by uplander View Post
my back plug is stuck in, tried several times
Did you try some lube?

Sent from my HTC One using Tapatalk 2
__________________
When I was a child, I used to talk as a child, think as a child, reason as a child; when I became a man, I put aside childish things.
1 Corinthians Chapter 13 - 11
Reply With Quote
  #15  
Old 10-03-2013, 11:11 PM
kevcliffbc kevcliffbc is offline
TT Regular
 
Join Date: Aug 2013
Boat: 2007 Mastercraft X-2, Indmar MCX
Location: Northwest
Posts: 40
Thanks for all the tips and info...I've been quietly lurking on the site for a bit and got comfortable seeing all the knowledge so figured I'd get an answer to my question with minimal flak.
Reply With Quote
  #16  
Old 10-04-2013, 10:50 AM
BrooksfamX2's Avatar
BrooksfamX2 BrooksfamX2 is offline
MC Devotee
 
Join Date: Dec 2011
Boat: 2007 MasterCraft X2
Location: Mid Left Coast
Posts: 1,664
Welcome to the X2 club. Where in the NW are you located?
__________________
MISS "B" HAVEN
2007 X2, Indmar 350 MCX
OJ 522 14.75 x 15.5
2006 F150 SCrew Puller
http://www.crowniehq.net
http://banners.wunderground.com/weat.../OR/Albany.gif
Reply With Quote
  #17  
Old 10-04-2013, 03:35 PM
kevcliffbc kevcliffbc is offline
TT Regular
 
Join Date: Aug 2013
Boat: 2007 Mastercraft X-2, Indmar MCX
Location: Northwest
Posts: 40
Quote:
Originally Posted by BrooksfamX2 View Post
Welcome to the X2 club. Where in the NW are you located?
British Columbia, Canada.
Reply With Quote
  #18  
Old 10-04-2013, 08:35 PM
BrooksfamX2's Avatar
BrooksfamX2 BrooksfamX2 is offline
MC Devotee
 
Join Date: Dec 2011
Boat: 2007 MasterCraft X2
Location: Mid Left Coast
Posts: 1,664
Oregon here.........
__________________
MISS "B" HAVEN
2007 X2, Indmar 350 MCX
OJ 522 14.75 x 15.5
2006 F150 SCrew Puller
http://www.crowniehq.net
http://banners.wunderground.com/weat.../OR/Albany.gif
Reply With Quote
  #19  
Old 10-04-2013, 10:25 PM
rgardjr1's Avatar
rgardjr1 rgardjr1 is offline
MC Devotee
 
Join Date: Oct 2008
Boat: Mastercraft, Maristar 200 SS, 2006, 5.7L Crusader
Location: Liberty Lake, WA
Posts: 1,002
Quote:
Originally Posted by kevcliffbc View Post
British Columbia, Canada.
Just drove up to Invermere last week on business.
__________________
2006 Maristar 200 SS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:17 PM.