Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 09-29-2013, 03:58 PM
h2oskiluvr's Avatar
h2oskiluvr h2oskiluvr is offline
TT Enthusiast
 
Join Date: Feb 2006
Boat: 2014 X10
Location: Midwest
Posts: 254
2013 x14v Computer stuck on "boot"

Out of the blue my nearly brand new boat's computer stopped working. I started it all up like I normally would and the computer never progressed beyond the boot mode. Bummer!

I turned everything off and on again like a dozen times. The engine and the analog gauges all worked fine. It is just the computer. So, no speed control etc until this is resolved.

Any suggestions for how I could address this? I would love to not take it to the dealer as that is such a pain in the butt.

Thanks!
Reply With Quote
  #2  
Old 09-29-2013, 05:26 PM
texasjet's Avatar
texasjet texasjet is offline
TT Enthusiast
 
Join Date: Dec 2009
Boat: X-Series, 30, 2008
Location: Texas - Richland Chambers
Posts: 216
Have you tried turning off the battery for several minutes, then turning back on and retry ?


Sent from my iPad using Tapatalk HD
Reply With Quote
  #3  
Old 09-29-2013, 05:34 PM
h2oskiluvr's Avatar
h2oskiluvr h2oskiluvr is offline
TT Enthusiast
 
Join Date: Feb 2006
Boat: 2014 X10
Location: Midwest
Posts: 254
I will try that.
Reply With Quote
  #4  
Old 09-29-2013, 07:10 PM
h2oskiluvr's Avatar
h2oskiluvr h2oskiluvr is offline
TT Enthusiast
 
Join Date: Feb 2006
Boat: 2014 X10
Location: Midwest
Posts: 254
So, I turned off all power. Waited a bit and tried it again. Nothing. I opened up the fuse panel and saw nothing that would indicate there was a problem and shut the door. Tried one last time and it started up???? So now it is working but I have no idea why. I will talk to the dealer on Monday.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:18 PM.