Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 04-15-2014, 01:11 AM
CrazyJohnny's Avatar
CrazyJohnny CrazyJohnny is offline
TT Newbie
 
Join Date: Jan 2014
Boat: Mastercraft, X10, 2006,5.7
Location: Norcal
Posts: 10
06 X10 Trans Intermittent Limp Mode

So I have had this "ghost" issue for a few years and it seem like no mechanic has been able to solve it for me. The transmission at idle speed keeps going into limp mode. After I shut the boat off, it resets itself. Sometime it will be fine other times it will no even go into gear. Runs perfect when towing skiers.

Fun Facts: 2006 Mastercraft X10 5.7 with Perfect Pass. Approx. 250 hrs.

- Summer 2012: Transmission rebuilt (shop said it would solve the issue because the trans was fried)

- Summer 2013: Local Certified Mastercraft mechanic briefly fixed issue but seemed to surface again later in the season.

I took her out yesterday for the first time this season. Started up and pulled off trailer. I drove the boat for around 25 minutes with no issues (speeds up to 35 mph). After I went to dock the boat threw first check engine light. I was in gear at idle speed coming into the dock when the check engine alarm went off. Water at dock was about 5 feet deep with grassy bottom. I shut the boat off and floated into the dock and tied off. After I left the dock (30 minutes later) the boat threw the code again (at idle speed). I turned the boat off, and it reset itself.

All in all in she threw the check engine code 10 times and thats when I finally pulled her onto the trailer. See the video, and excuse my narration, I was trying to teach the girlfriend basics of boat navigation Lets just say I sound pretty dumb on there....

https://www.youtube.com/watch?v=SHdZ...m-upload_owner


Thanks for the help guys!

- Johnny
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:19 AM.