Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Trailers

Reply
 
Thread Tools Display Modes
  #1  
Old 07-16-2015, 03:14 PM
ac505 ac505 is online now
TT Enthusiast
 
Join Date: Jul 2013
Boat: 2000 Xstar
Location: somewhere cold and wet
Posts: 262
Damn, overheated the brakes....

UK trailer so a little different to the American ones. Primarily, the brakes are cable operated.

Long story cut short, a little maintenance on the draw bar and I adjusted the brakes a fraction too tight. Annoyingly bearings and brake shoes are all new so I hope I haven't trashed too much.

Trailered about 10 miles and noticed things were a bit hot, like can't touch the wheel hot. We launched the boat and there was the distinctive boiling of water sound for about 1 second and a little oil shimmering in the water (could have been from the last boat). We didn't hang around to let the brakes cool,which I know I should have done. My guess I need to replace the grease at a minimum and inspect the bearings for blueing. I'll do a visual on the brake shoes. Anything else to consider?
Reply With Quote
  #2  
Old 07-16-2015, 04:17 PM
pondo pondo is offline
TT Regular
 
Join Date: Jun 2015
Boat: 2005 Mastercraft X-2
Location: VA
Posts: 41
Good chance you could have warped the drum due to the quick thermal cycle. If you had disc brakes I'd say for sure it'd be warped.
Reply With Quote
  #3  
Old 07-16-2015, 05:01 PM
ac505 ac505 is online now
TT Enthusiast
 
Join Date: Jul 2013
Boat: 2000 Xstar
Location: somewhere cold and wet
Posts: 262
Hopefully not! I readjusted the brakes and all seemed fine for the 10 miles home.

Pulled one drum apart today, everything looks fine, I changed the grease and re packed the bearings. Will keep,an eye on the other 3 but hopefully no lasting damage.

Last edited by ac505; 07-17-2015 at 12:26 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:08 AM.