Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 09-03-2013, 11:41 AM
X2AL X2AL is offline
TT Newbie
 
Join Date: Sep 2013
Boat: 2013 X2
Location: Midwest
Posts: 1
Angry 2013 X2 Electrical Nightmare

Is anyone haveing issues with a 2013 mastercraft? I have a brand new X2 and have been having major electrical issues with it. Started off with Speedo issues. Not really issues but it did not work period. Mine is all GPS based so they replace the black box unit in front of the windsheild. It worked for a few weeks then gone again. Replaced again. Now its been intermittent. Replaced again and still interemittent. Also the center bilge pump is malfuntioning and running all night and day twice killing my batteries complteley. This has been replaced once already. I am currently experiancing a new issues and that is my fuel gauge is reading Empty at all times. And yes there is gas in it. I decided to trade up from my 2006 Malibu wakesetter that I had only one problem with since I bought it new in 06 to the Elite Mastercraft boat. Well I am not gettting the warm and fuzzies on my new purchase. The one year warrenty on all these electronics is not helping the sitution any. My dealer has been great in taking care of me but I beleive my issues may be more than they can handle. Any info would be greatly appreciated. I am in the automotive industry and sometimes you just get a car that is a lemon. Any lemon law on boats? Thinking of going back to Malibu? Very frustarted new mastercraft owner.
Reply With Quote
  #2  
Old 09-03-2013, 11:48 AM
gweaver gweaver is offline
MC Fanatic
 
Join Date: Aug 2011
Boat: 1988 Prostar 190
Location: Northern California
Posts: 508
I would think you'd want to check with your state attorney's office about lemon law and procedures. That being said, since the dealer has been helpful and has tried to resolve the issue, I'd be inclined to encourage them to start talking to MC about getting a new boat/having yours sent back to the factory/factory tech coming out to trouble shoot. Maybe the dealer can work something out with MC without you having to lawyer up.
G
Reply With Quote
  #3  
Old 09-03-2013, 12:18 PM
stuartmcnair's Avatar
stuartmcnair stuartmcnair is offline
MC Devotee
 
Join Date: Sep 2007
Boat: 1989 Prostar 190 351 Indmar
Location: Tuscaloosa
Posts: 1,143
Send a message via MSN to stuartmcnair
A nice conversation with the dealer stating that you want the factory involved will probably be your best bet. I agree with above about leaving an attorney (or the threat of one) out at this point. Give MC a chance.
Reply With Quote
  #4  
Old 09-03-2013, 12:22 PM
rtw_travel's Avatar
rtw_travel rtw_travel is offline
TT Enthusiast
 
Join Date: Sep 2012
Boat: 2014 X-14V
Location: Alberta, Canada
Posts: 244
We've had similar problems with our 2012 which seem to be related to the CAN bus. Basically the engine, transmission, blower and running lights work flawlessly, but nothing else worked. Literally nothing else: we had no gauges of any kind, no cruise control, no A plate, and no ballast pumps.

Of course we were upset. We bought the boat for watersports, but every part of the boat that was important for watersports did not work.

The dealer was pretty good, and I know they have worked hard with Mastercraft to resolve issues. There's still some details to work through, but so far I am impressed with both the local dealer and with MasterCraft's desire to stand by their product.

Yes, it's frustrating - you didn't spend this much money on a boat to have it fail like this. You may have legal options, however I agree with above - work through the dealer to get a satisfactory resolution.

Good luck
__________________
2014 X-14V
2012 X-14V (gone)
Reply With Quote
  #5  
Old 09-03-2013, 12:28 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 11,404
Send a message via Skype™ to mikeg205
I am sure Action Sports is willing to help - they are a great bunch of people. I agree with Stuart - every manufacture is going to have an issue here and there. I recommend being very methodical with getting this resolved with dealer and MC.

Not a nice experience - as I would be very frustrated as well. I would say nothing about the states attorney or lawyering up - since that immediately changes all the rules.

And now with all the winterizations scheduled in - this may take some extra time - I would keep a positive attitude and work closely with dealer and MC - I am sure they both would like it resolved as much as you.
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #6  
Old 09-03-2013, 06:16 PM
Lucky26 Lucky26 is offline
TT Enthusiast
 
Join Date: Mar 2012
Boat: 2013 X-25 6.0 Pro Package
Location: Southeast Texas
Posts: 154
Quote:
Originally Posted by X2AL View Post
Is anyone haveing issues with a 2013 mastercraft? I have a brand new X2 and have been having major electrical issues with it. Started off with Speedo issues. Not really issues but it did not work period. Mine is all GPS based so they replace the black box unit in front of the windsheild. It worked for a few weeks then gone again. Replaced again. Now its been intermittent. Replaced again and still interemittent. Also the center bilge pump is malfuntioning and running all night and day twice killing my batteries complteley. This has been replaced once already. I am currently experiancing a new issues and that is my fuel gauge is reading Empty at all times. And yes there is gas in it. I decided to trade up from my 2006 Malibu wakesetter that I had only one problem with since I bought it new in 06 to the Elite Mastercraft boat. Well I am not gettting the warm and fuzzies on my new purchase. The one year warrenty on all these electronics is not helping the sitution any. My dealer has been great in taking care of me but I beleive my issues may be more than they can handle. Any info would be greatly appreciated. I am in the automotive industry and sometimes you just get a car that is a lemon. Any lemon law on boats? Thinking of going back to Malibu? Very frustarted new mastercraft owner.
I have a 13 X-25 and the gas gauge has never worked. I took it in for first service and the dealer said it was the gauge itself. We replaced the gauge and still no reading. I was told that they are having issues with some of the floats so I am guessing we will try that next.
Reply With Quote
  #7  
Old 09-03-2013, 06:50 PM
rtw_travel's Avatar
rtw_travel rtw_travel is offline
TT Enthusiast
 
Join Date: Sep 2012
Boat: 2014 X-14V
Location: Alberta, Canada
Posts: 244
Quote:
Originally Posted by X2AL View Post
The one year warrenty on all these electronics is not helping the sitution any.
My recollection is that electronics have a three year warranty, not one. There may be an exception for the depth gauge and zero off (check your manual), but they probably have their own warranty.
__________________
2014 X-14V
2012 X-14V (gone)
Reply With Quote
  #8  
Old 09-04-2013, 07:21 AM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,333
Based on your experience I would be looking to get a free extended warranty or at least one for cost. Seems to me if this issue has not been resolved during warranty and persists after it should still be covered as it was never fixed since day one.

I've dealt with Action in the past and they've been great to work with. They have been a solid dealer since opening. Have you talked to the owner directly? Have you discussed an action plan going forward to resolve these issues and protect your investment? I would certainly be looking for some kind of reassurance all these issues will be resolved and something in writing like an extended warranty would certainly go a long way in my book to make me feel better.
Reply With Quote
  #9  
Old 09-04-2013, 07:37 AM
Stefan's Avatar
Stefan Stefan is offline
MC Fanatic
 
Join Date: Apr 2012
Boat: 2014 X-46 6.0L BSO-II Gen2+
Location: middle of Germany, center of Europe
Posts: 522
Quote:
Originally Posted by X2AL View Post
Is anyone haveing issues with a 2013 mastercraft? I have a brand new X2 and have been having major electrical issues with it. Started off with Speedo issues. Not really issues but it did not work period. Mine is all GPS based so they replace the black box unit in front of the windsheild. It worked for a few weeks then gone again. Replaced again. Now its been intermittent. Replaced again and still interemittent. Also the center bilge pump is malfuntioning and running all night and day twice killing my batteries complteley. This has been replaced once already. I am currently experiancing a new issues and that is my fuel gauge is reading Empty at all times. And yes there is gas in it. I decided to trade up from my 2006 Malibu wakesetter that I had only one problem with since I bought it new in 06 to the Elite Mastercraft boat. Well I am not gettting the warm and fuzzies on my new purchase. The one year warrenty on all these electronics is not helping the sitution any. My dealer has been great in taking care of me but I beleive my issues may be more than they can handle. Any info would be greatly appreciated. I am in the automotive industry and sometimes you just get a car that is a lemon. Any lemon law on boats? Thinking of going back to Malibu? Very frustarted new mastercraft owner.
Oh well another throughly lake tested boat...
I had similar problems with a 2012 so I gained some knowledge of the boats electronics...

Suggestions for finding the reasons why the speedo doesn't work: with ignition turned off disconnect the GPS Sensor in front of the windshield (plug right underneat the hull behind the seatback), the system should then revert to PerfectPass and show that in the touchscreen, see if you speedo stays dead. Suggestion to exchange the speedo completely since it's the main and central user electronics element present in all the boats (at least in 2012 that is) dont't forget pitch and roll calibration afterwards...

The blige should have the malfunction switch inside, so a full exchange should solve it...
__________________
If You Find To Many Capitals You Can Keep Them...I'm German
Reply With Quote
  #10  
Old 09-04-2013, 08:54 AM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,598
Quote:
Originally Posted by X2AL View Post
Is anyone haveing issues with a 2013 mastercraft? I have a brand new X2 and have been having major electrical issues with it. Started off with Speedo issues. Not really issues but it did not work period. Mine is all GPS based so they replace the black box unit in front of the windsheild. It worked for a few weeks then gone again. Replaced again. Now its been intermittent. Replaced again and still interemittent. Also the center bilge pump is malfuntioning and running all night and day twice killing my batteries complteley. This has been replaced once already. I am currently experiancing a new issues and that is my fuel gauge is reading Empty at all times. And yes there is gas in it. I decided to trade up from my 2006 Malibu wakesetter that I had only one problem with since I bought it new in 06 to the Elite Mastercraft boat. Well I am not gettting the warm and fuzzies on my new purchase. The one year warrenty on all these electronics is not helping the sitution any. My dealer has been great in taking care of me but I beleive my issues may be more than they can handle. Any info would be greatly appreciated. I am in the automotive industry and sometimes you just get a car that is a lemon. Any lemon law on boats? Thinking of going back to Malibu? Very frustarted new mastercraft owner.
Time to have a conversation with the service manager about the level of technical training for their techs. If they can't find definitive causes for your boat's problems, it's time for more training.

While I admit that electrical problems are often hard to track down, there's still no excuse for not being able to.

Where, in the Midwest?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:19 PM.