Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 06-05-2016, 04:27 AM
Joverby1993 Joverby1993 is offline
TT Newbie
 
Join Date: Jun 2016
Boat: 1995 MasterCraft prostar 205
Location: East Coast
Posts: 3
1995 Mastercraft Prostar 205 TBI no spark

Bought this boat last week, ran fine on water test driving. Brought it home sat for one day and then it wouldn't start. TBI is good have fuel, replaced the distributor cap and rotor button fired up and ran the boat at the lake and ran perfect. Brought it home and it sat for another day or two pulled it around to run it in the yard and again it was getting no spark. So I replaced the Ignition Module under the distributor cap started up and boat idled in yard for 10 mins with water hooked up. Thinking I fixed the problem I took it to the lake the next day backed it down to the water and again it would not start no fire to the plugs. What in the world am I missing or would cause it to run fine one day and then not even start the day after. PLEASE SOMEONE HELP!!!!
Reply With Quote
  #2  
Old 06-05-2016, 08:34 AM
Double D's Avatar
Double D Double D is offline
MC Addict
 
Join Date: Sep 2004
Boat: 1994 Mastercraft, ProStar 205, 350 Indmar with 275 hp
Location: UCLA (Upper Canton, Lower Akron)
Posts: 5,817
Maybe a bad lanyard / kill switch plug? I'd check that.
__________________
If its not a competition ski boat, its always second best.

1994 MasterCraft ProStar 205
275 HP 350 Chevy Indmar
Monster Tower & PerfectPass

Check out the MasterCraft Buckeye Bash on Facebook!


"In my many years I have come to a conclusion that one useless man is a shame, two is a law firm and three or more is a congress." - John Adams
Reply With Quote
  #3  
Old 06-05-2016, 08:43 AM
Joverby1993 Joverby1993 is offline
TT Newbie
 
Join Date: Jun 2016
Boat: 1995 MasterCraft prostar 205
Location: East Coast
Posts: 3
I've pulled the lanyard and it kills fuel pump. Put lanyard back on fuel pump comes on still no fire.
Reply With Quote
  #4  
Old 06-05-2016, 08:50 AM
Joverby1993 Joverby1993 is offline
TT Newbie
 
Join Date: Jun 2016
Boat: 1995 MasterCraft prostar 205
Location: East Coast
Posts: 3
Could the ignition switch cause problems like this. I noticed I the key has to be upside down in switch and the actual switch sometimes rotates while turning key on and off.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:04 AM.