Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 09-02-2013, 08:33 PM
Topp dawg Topp dawg is offline
TT Enthusiast
 
Join Date: Jun 2013
Boat: 2003 Mastercraft X10
Location: Southeast
Posts: 280
Blower help.

Today my blower would not work at all on my 2003 x10. I unplugged it and plugged it back in and that did not work. It is not tripping the breaker. I also have a check engine light on. Could the check engine be related to the blower not working?

Is there any other troubleshooting I can do to get the blower working, or should I just replace it?
Reply With Quote
  #2  
Old 09-02-2013, 08:44 PM
Footin's Avatar
Footin Footin is offline
MC Maniac
 
Join Date: Aug 2004
Boat: 2007 Maristar 200VRS X2
Location: Columbus,OH/Monticello,KY
Posts: 4,995
Use a test light to verify you have power the the blower first.
__________________
OH-IO!
Reply With Quote
  #3  
Old 09-02-2013, 08:45 PM
Spork's Avatar
Spork Spork is offline
MC Maniac
 
Join Date: May 2010
Boat: Sporkcraft
Location: South
Posts: 3,631
Quote:
Originally Posted by Topp dawg View Post
Today my blower would not work at all on my 2003 x10. I unplugged it and plugged it back in and that did not work. It is not tripping the breaker. I also have a check engine light on. Could the check engine be related to the blower not working?

Is there any other troubleshooting I can do to get the blower working, or should I just replace it?
The blower will not cause the check engine light, First I would see if your getting voltage at the blower with it turned on with a multimeter that will tell you if it's burned up or if you have an electrical issue.
__________________
/spôrk/
a spoon-shaped eating utensil with short tines at the tip
Reply With Quote
  #4  
Old 09-02-2013, 09:38 PM
Topp dawg Topp dawg is offline
TT Enthusiast
 
Join Date: Jun 2013
Boat: 2003 Mastercraft X10
Location: Southeast
Posts: 280
If it is getting power then should i just replace the blower?
Reply With Quote
  #5  
Old 09-02-2013, 10:08 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is online now
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 17,231
After confirming it has a good ground.
__________________
Peter
S5 WHEEL SALE POLISHED\CLEARCOATED ALUMINUM
TWO 14" @ $149, FOUR 14" @ $259, TWO 15" @ $169 (5 OR 6 LUG)


SNOWMOBILE TRAILER PACKAGE $229
TWO 20X8.50-10 KENDA LOADSTAR LOAD RANGE E TIRES
TWO S5 GUNMETAL W/CHROME LIP ALUMINUM WHEELS

2 LED REPLACEMENT BRAKE LIGHTS $29
SAME LIGHT WORKS ON YOUR SNOWMOBILE TRAILER

HITCH & COUPLER LOCK KEYED ALIKE $39
REBUILDING HOLLEY MARINE 4160 CARBURETORS - $225 DELIVERED
Email - tiresplease@gmail.com
Reply With Quote
  #6  
Old 09-03-2013, 12:55 PM
Topp dawg Topp dawg is offline
TT Enthusiast
 
Join Date: Jun 2013
Boat: 2003 Mastercraft X10
Location: Southeast
Posts: 280
I went out to troubleshoot the blower today and before I could do anything I just wanted to check it one last time and it worked, like magic. I tried it 10 more times and it worked every time. No clue why it worked today or even why it stopped working the other day. My boat may have a ghost. Check engine light is still on though.
Reply With Quote
  #7  
Old 09-03-2013, 01:09 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is online now
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 17,231
You may have a corroded connection, a switch getting ready to fail or your blower may be on it's last legs. Looking at the connections is the easy part. Good luck.
__________________
Peter
S5 WHEEL SALE POLISHED\CLEARCOATED ALUMINUM
TWO 14" @ $149, FOUR 14" @ $259, TWO 15" @ $169 (5 OR 6 LUG)


SNOWMOBILE TRAILER PACKAGE $229
TWO 20X8.50-10 KENDA LOADSTAR LOAD RANGE E TIRES
TWO S5 GUNMETAL W/CHROME LIP ALUMINUM WHEELS

2 LED REPLACEMENT BRAKE LIGHTS $29
SAME LIGHT WORKS ON YOUR SNOWMOBILE TRAILER

HITCH & COUPLER LOCK KEYED ALIKE $39
REBUILDING HOLLEY MARINE 4160 CARBURETORS - $225 DELIVERED
Email - tiresplease@gmail.com
Reply With Quote
  #8  
Old 09-03-2013, 03:24 PM
Topp dawg Topp dawg is offline
TT Enthusiast
 
Join Date: Jun 2013
Boat: 2003 Mastercraft X10
Location: Southeast
Posts: 280
The connections on the battery do look corroded. Can I just use contact cleaner and a wire brush?
Reply With Quote
  #9  
Old 09-03-2013, 03:33 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is online now
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 17,231
Yup. Stainless wire brush does an especially good job.
__________________
Peter
S5 WHEEL SALE POLISHED\CLEARCOATED ALUMINUM
TWO 14" @ $149, FOUR 14" @ $259, TWO 15" @ $169 (5 OR 6 LUG)


SNOWMOBILE TRAILER PACKAGE $229
TWO 20X8.50-10 KENDA LOADSTAR LOAD RANGE E TIRES
TWO S5 GUNMETAL W/CHROME LIP ALUMINUM WHEELS

2 LED REPLACEMENT BRAKE LIGHTS $29
SAME LIGHT WORKS ON YOUR SNOWMOBILE TRAILER

HITCH & COUPLER LOCK KEYED ALIKE $39
REBUILDING HOLLEY MARINE 4160 CARBURETORS - $225 DELIVERED
Email - tiresplease@gmail.com
Reply With Quote
  #10  
Old 09-03-2013, 04:58 PM
Topp dawg Topp dawg is offline
TT Enthusiast
 
Join Date: Jun 2013
Boat: 2003 Mastercraft X10
Location: Southeast
Posts: 280
Thanks man
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:07 PM.