Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #21  
Old 08-03-2013, 11:11 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is online now
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 14,716
Could have been worse than that.
__________________
Peter

Tandem Axle Wheel & Tire Package $659
4 S5 or S5 Black 14x5.5 wheels, 4 ST205/75R14 Kenda Loadstar tires

Single Axle Wheel & Tire Package $399
2 S5 or S5 Black 14x5.5 wheels, 2 ST215/75R14 Kenda Loadstar tires
MOUNT, BALANCE & FREE SHIPPING INCLUDED IN BOTH PACKAGES



CARB REBUILDING - FAST TURN-AROUND - $100 +PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts - Red, Blue & Black


PM or email me tiresplease@gmail.com
Reply With Quote
  #22  
Old 08-03-2013, 11:32 AM
College Kid's Avatar
College Kid College Kid is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: 93 Prostar 190
Location: St. Albert, Canada
Posts: 191
Yeah, it actually isn't that bad. Damper plate and block plate are really the only really ruined parts, and I had already planed to replace the Damper, so I can't really complain.

Does anyone have a source for the block plate? Can't seem to find it on skidim.com
Reply With Quote
  #23  
Old 08-03-2013, 12:44 PM
Cloaked Cloaked is offline
MC Maniac
 
Join Date: Dec 2004
Boat: MasterCraft
Location: Kingston,TN USA
Posts: 4,601
Quote:
Originally Posted by College Kid View Post
Yeah, it actually isn't that bad. Damper plate and block plate are really the only really ruined parts, and I had already planed to replace the Damper, so I can't really complain.

Does anyone have a source for the block plate? Can't seem to find it on skidim.com
http://www.partman.com/


http://bpi.ebasicpower.com/c/ALL3/Ve...and_Parts.html

.
/
__________________
93 190
.
Don't be a boot licker
.

Hose picture (internal) http://www.mastercraft.com/teamtalk/...68&postcount=8



Quote:
Originally Posted by Thrall View Post
..Some of you give a whole new meaning to the phrase "another @sshole with a Mastercraft."

RE: Thrall, Welcome to the club....
NEW SKINS in TN... Leading Edge Marine Interior

feedback on a TN company: http://www.mastercraft.com/teamtalk/...ad.php?t=58767

.

Last edited by Cloaked; 08-03-2013 at 06:01 PM.
Reply With Quote
  #24  
Old 08-04-2013, 03:03 PM
College Kid's Avatar
College Kid College Kid is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: 93 Prostar 190
Location: St. Albert, Canada
Posts: 191
I am able to find the damper plates on those sites but can't seem to find the block plate.

The one that goes between the bell housing and the engine block???
Reply With Quote
  #25  
Old 08-04-2013, 06:25 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,473
Send a message via Skype™ to mikeg205
I would give michigan motorz a call ... http://www.michiganmotorz.com/
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #26  
Old 08-08-2013, 05:23 PM
College Kid's Avatar
College Kid College Kid is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: 93 Prostar 190
Location: St. Albert, Canada
Posts: 191
thought I was off to a good start. Have the fly wheel off, and was able to remove the ring gear. But have run into some issues. Does anyone know a napa # or another supplier for a ring gear that will fit the 351W? I thought it was a 157 tooth, but I have ordered in two separate ones and neither of them fit. I am trying to source something local, before having to pay shipping from skidim.com.
Reply With Quote
  #27  
Old 08-24-2013, 12:43 PM
College Kid's Avatar
College Kid College Kid is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: 93 Prostar 190
Location: St. Albert, Canada
Posts: 191
Well it's all back together!!!

Took me a little longer than I might have liked but I am finally back in business.

Now have a new problem. Went to start it and it spins, but doesn't seem to get spark???????

I've double checked all my wiring, and it seems fine. Just feels like it's not getting spark.

The only thing I can come up with is maybe I need to check the timing after replacing the flywheel??? can someone confirm?

Or any other thoughts on what to look at?
Reply With Quote
  #28  
Old 08-24-2013, 01:08 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,473
Send a message via Skype™ to mikeg205
is the coil firing? 93 - I am not familiar with that ignition... could be ignition module...
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #29  
Old 08-24-2013, 01:20 PM
College Kid's Avatar
College Kid College Kid is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: 93 Prostar 190
Location: St. Albert, Canada
Posts: 191
Quote:
Originally Posted by mikeg205 View Post
is the coil firing? 93 - I am not familiar with that ignition... could be ignition module...
How would I check that? Also what is the best way to check for at the plugs?
Reply With Quote
  #30  
Old 08-24-2013, 01:24 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,473
Send a message via Skype™ to mikeg205
Quote:
Originally Posted by College Kid View Post
How would I check that? Also what is the best way to check for at the plugs?
Voltmeter
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:26 PM.