Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 07-09-2013, 04:09 AM
Calam74 Calam74 is offline
TT Newbie
 
Join Date: Jul 2013
Boat: X45 2006
Location: West Europe
Posts: 3
X45 ballast connections

Hello Everyone, excuse me in advance for my bad english...

All our turbines inside pumps are new and the ballast fill and get emply very badly.
I think we just not connect the right tubes in the right pumps or there should be something else...

Can I ask someone to send me pictures of the connections between the pipes and the pumps?
Or a shema?

Thanks in advance

Bye
Reply With Quote
  #2  
Old 07-12-2013, 05:02 AM
Calam74 Calam74 is offline
TT Newbie
 
Join Date: Jul 2013
Boat: X45 2006
Location: West Europe
Posts: 3
Does anyone can help me please on this issue?
Any ideas?
Any pictures or shema??

Thanks in advanced
Reply With Quote
  #3  
Old 07-17-2013, 03:29 AM
Calam74 Calam74 is offline
TT Newbie
 
Join Date: Jul 2013
Boat: X45 2006
Location: West Europe
Posts: 3
Maybe you guys don't understand what I'm trying to explain...

I was used that water went out from the front right side on the boat but NOW it doesn't..
It empty all ballast from both sides of the back, which is terribly long..

Other problem: my port gauge doesn't work anymore, so I can't see how full or empty is the ballast tank..

Thanks in advance for your reply
Reply With Quote
  #4  
Old 07-17-2013, 07:04 AM
TN X-45's Avatar
TN X-45 TN X-45 is online now
MC Fanatic
 
Join Date: Apr 2010
Boat: Mastercraft X-45 2008 MCX
Location: Southeast - Allatoona
Posts: 524
Your port gauge is likely a bad sender. I just had to replace 2 on my 2008.

Sent from my SCH-I535 using Tapatalk 2
__________________
2008 X-45 Canadian Blue Metal Flake/Silver Metal Flake, MCX, OJ 5 Blade
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:59 AM.