Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 06-26-2013, 03:46 PM
Avman2119 Avman2119 is offline
TT Newbie
 
Join Date: Jun 2013
Boat: Mastercraft, Prostar 205, 1993, Indmar 351
Location: Midwest
Posts: 3
93 Prostar 205 Speedometer Broke

How can I troubleshoot why my speedometer doesn't work? I know it doesn't work just need to figure out which piece of it doesn't work.
Reply With Quote
  #2  
Old 06-26-2013, 04:15 PM
j.mccreight@hotmail.com's Avatar
j.mccreight@hotmail.com j.mccreight@hotmail.com is online now
MC Maniac
 
Join Date: May 2010
Boat: 1989 MasterCraft TriStar 190 SE
Location: Houston, TX
Posts: 3,309
First, clean out the pitot at the aft of boat with a paper clip or like item
Second, remove hoses from pitot and the speedometer head, blow out hose with compressed air
Third, use a mighty vac and apply air pressure to speedometer head and see if it reads, caution a little pressure goes a long way you don't want to blow the diaphragm in the speedo head, if the boat has damper tubes, disconnect and work around those.
With doing these checks it should be easy to diagnosis and fix your issue.
Attached Images
 
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:56 AM.