Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 06-26-2013, 12:23 PM
colin382 colin382 is offline
TT Newbie
 
Join Date: May 2013
Boat: Mastercraft 205 Formula 382
Location: mid atlantic
Posts: 4
boat died while running

my 2000 205 prostar was running great and just stopped while running down the river nothing when I turn key nothing, no gauge movement no alarm whole dash is dead could that be my MDC box if it was my kill switch it would still crank correct? battery is fine my radio is direct wired to it and works
Reply With Quote
  #2  
Old 06-26-2013, 12:25 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 9,351
Send a message via Skype™ to mikeg205
Yes kill switch would allow engine to turn.

check connections... could be corrosion. Is there power to the dash?
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #3  
Old 06-26-2013, 12:31 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 13,905
Ground wire at the block is a likely culprit.
__________________
Peter

Tandem Axle Trailer Special
Includes: 4 T07 wheels, 4 ST205/75R14 Kenda
Loadstar KR03 Radial tires, mount and balance
Free Delivery


ALUMINUM WHEEL AND TIRE PACKAGES
SINGLE AXLE 14" PACKAGE STARTING AT $369
SINGLE AXLE 15" PACKAGE STARTING AT $439
TANDEM AXLE 14" PACKAGE STARTING AT $649
LED lights, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts
GOLF CART TIRES & WHEELS

PM me or email tiresplease@gmail.com
Reply With Quote
  #4  
Old 06-26-2013, 01:00 PM
colin382 colin382 is offline
TT Newbie
 
Join Date: May 2013
Boat: Mastercraft 205 Formula 382
Location: mid atlantic
Posts: 4
no dash is dead gauges stuck in position they were in when boat died
Reply With Quote
  #5  
Old 06-26-2013, 01:15 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 9,351
Send a message via Skype™ to mikeg205
Quote:
Originally Posted by colin382 View Post
no dash is dead gauges stuck in position they were in when boat died
sorry what I mean is there voltage at the connection to the dash or the MDC unit.
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #6  
Old 06-26-2013, 01:50 PM
colin382 colin382 is offline
TT Newbie
 
Join Date: May 2013
Boat: Mastercraft 205 Formula 382
Location: mid atlantic
Posts: 4
don't kno will find out that would make a lot of sense thanks
Reply With Quote
  #7  
Old 07-07-2013, 01:43 PM
Mookster Mookster is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 2001 Prostar 205V
Location: Midwest
Posts: 7
I have the same symptoms as Colin382, with a 2001 Prostar 205V. Middle of mild acceleration on the lake, boat went dead, gauges frozen in place, can crank the starter, but no spark. Boat was running great for the last 3 days, and had been running for about 35 mins before the incident.

Have checked and jumped the kill switch, and found that the "accsy 2" breaker is popping when kill switch is bypassed. Bypassed the accsy 2 breaker with a 25a fuse, and that blew the same way, soon as key is turned "on"

Would LOVE to hear if anyone has any ideas or similar issues they worked through. Has me stumped (as well as my car-guy brother in law..)
Reply With Quote
  #8  
Old 07-07-2013, 01:46 PM
Mookster Mookster is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 2001 Prostar 205V
Location: Midwest
Posts: 7
Oh, and I do have 12v to the dash rocker switches and my depth guage turns on with key, but not sure if I have power to the MDC, will check that shortly.
Reply With Quote
  #9  
Old 07-07-2013, 01:57 PM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,349
Quote:
Originally Posted by colin382 View Post
my 2000 205 prostar was running great and just stopped while running down the river nothing when I turn key nothing, no gauge movement no alarm whole dash is dead could that be my MDC box if it was my kill switch it would still crank correct? battery is fine my radio is direct wired to it and works
Check the breaker on the engine.
Reply With Quote
  #10  
Old 07-07-2013, 02:20 PM
Mookster Mookster is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 2001 Prostar 205V
Location: Midwest
Posts: 7
Thanks for the quick reply! Breaker at engine was checked (double checked), that was my first idea after checking the kill switch.

After further troubleshooting, we have found that we don't have power to the Coil, no 12v showing up on the 4 wires coming into the coil. With key in RUN position, or when cranking the starter.

Checking to make sure there is power at MDC now.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:05 AM.