Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-02-2013, 01:46 AM
BoulderX45 BoulderX45 is offline
TT Enthusiast
 
Join Date: Dec 2006
Boat: MC, X-45, 2006, LQ9
Location: Northwest
Posts: 191
Ballast Pump Replacement

I just had a ballast pump fail in my 06 x-45. Do I replace it with the Jabsco (current pump) or Johnson? Does the Johnson have the same hole pattern? Same power plug? Does it pump more then the Jabsco as stated?

Thanks,
Boulderx45
Reply With Quote
  #2  
Old 07-02-2013, 08:15 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,088
You could use either one. Everything I've read says there really is no noticeable difference in the pump rates.
__________________
Tim
Gone, surfing.
Reply With Quote
  #3  
Old 07-02-2013, 08:49 AM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,244
Wakemakers told me to replace with the same as what was installed when I looked into going to the Johnsons. You'll need to cut and solder the connector onto the new pump unless you buy the pump directly from MC).
Reply With Quote
  #4  
Old 07-02-2013, 09:33 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,088
Or you can get a set of pins and then just repin the old connector.

http://www.deutschconnector.com/prod...es_connectors/
__________________
Tim
Gone, surfing.
Reply With Quote
  #5  
Old 07-02-2013, 09:42 AM
ZachDaddy's Avatar
ZachDaddy ZachDaddy is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: MasterCraft, X15, 2007, MCX, Acme 5 Blade, Pair of WetSounds Rev410's, WetSounds SD6, 2 JL 12w6v2 subs in sealed box, JL HD750/1, WS402SQ
Location: Southeast
Posts: 247
My buddy's pump failed and he had his rebuilt for $75 dollars at a local alternator shop. I've helped a number of others on this forum with the same problem.
Reply With Quote
  #6  
Old 07-02-2013, 10:00 AM
BrooksfamX2's Avatar
BrooksfamX2 BrooksfamX2 is online now
MC Devotee
 
Join Date: Dec 2011
Boat: 2007 MasterCraft X2
Location: Mid Left Coast
Posts: 1,591
Had my port side pump failed last week. Bound up like the bearings are shot. Replaced with a Jabsco from Wake Makers last night. They shipped it overnight for free!!!

Will autopsy the old one to see what's going on. Will refurb and keep as a spare.
Need to turn them over so they don't leak into the motor...........
__________________
MISS "B" HAVEN
2007 X2, Indmar 350 MCX
OJ 522 14.75 x 15.5
2006 F150 SCrew Puller
http://www.crowniehq.net
http://banners.wunderground.com/weat.../OR/Albany.gif
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:55 AM.