Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #11  
Old 06-18-2013, 11:38 AM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,599
This is a good thread regarding LT-1 cooling:
http://www.mastercraft.com/teamtalk/...ad.php?t=31626
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #12  
Old 06-18-2013, 11:56 AM
towelshoot towelshoot is offline
TT Regular
 
Join Date: Jun 2013
Boat: 95 Maristar 225
Location: Midwest
Posts: 41
Thanks Table Rocker. Well ordered the pump, so now just need to wait for arrival. Not sure yet if I will paint it or not. I guess I should - yours looks great. Any particular type of paint I should use?
Reply With Quote
  #13  
Old 06-18-2013, 12:04 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,599
I used Dupli-Color engine enamel available at your local part store.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #14  
Old 06-22-2013, 03:59 PM
towelshoot towelshoot is offline
TT Regular
 
Join Date: Jun 2013
Boat: 95 Maristar 225
Location: Midwest
Posts: 41
New pump is painted. Old pump is off. Trying to clean the gaskets off the block - could use suggestion here if anyone has one.
Reply With Quote
  #15  
Old 06-22-2013, 06:41 PM
Daubrey Daubrey is offline
TT Newbie
 
Join Date: Jun 2013
Boat: 95 190 with LT1
Location: Southeast
Posts: 24
What is the recommended maintenance on this water pump? I have a 95 with the LT1, and to my knowledge, it has never been addressed!
Reply With Quote
  #16  
Old 06-22-2013, 06:51 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,599
Quote:
Originally Posted by towelshoot View Post
New pump is painted. Old pump is off. Trying to clean the gaskets off the block - could use suggestion here if anyone has one.
Single edged razor blade for the final clean up works well for me.

Quote:
Originally Posted by Daubrey View Post
What is the recommended maintenance on this water pump? I have a 95 with the LT1, and to my knowledge, it has never been addressed!
Run it until it leaks from the weep hole is all you can do.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #17  
Old 06-23-2013, 09:24 PM
towelshoot towelshoot is offline
TT Regular
 
Join Date: Jun 2013
Boat: 95 Maristar 225
Location: Midwest
Posts: 41
Done

All installed and working good. No leaking.

Well at least now I am up and able to run. I can do the rest of my projects while using it.

Thanks for all the help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:14 AM.