Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #11  
Old 06-17-2013, 08:21 PM
Aric'sX15's Avatar
Aric'sX15 Aric'sX15 is offline
MC Maniac
 
Join Date: Nov 2007
Boat: Mainship Pilot 30
Location: Corinth
Posts: 3,112
2 channel could work too. had a Wetsounds Syn 2 two channel on my 4 pro 80's
__________________
"if one day the speed kills me, do not cry because i was smiling." -Paul Walker
Reply With Quote
  #12  
Old 06-17-2013, 08:21 PM
hughes26 hughes26 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2013 X-30 6.0L
Location: Southeast
Posts: 31
JL - M400/4 Tower Speakers
JL - M700/5 for cockpit and sub
Reply With Quote
  #13  
Old 06-17-2013, 08:23 PM
hughes26 hughes26 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2013 X-30 6.0L
Location: Southeast
Posts: 31
JL - M400/4 Tower Speakers
JL - M700/5 Cockpit and Sub
Reply With Quote
  #14  
Old 06-17-2013, 08:24 PM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,076
Quote:
Originally Posted by hughes26 View Post
JL - M400/4 Tower Speakers
JL - M700/5 Cockpit and Sub
So 4x100 to the 4 speakers and 300 to the sub?
Reply With Quote
  #15  
Old 06-17-2013, 08:26 PM
Aric'sX15's Avatar
Aric'sX15 Aric'sX15 is offline
MC Maniac
 
Join Date: Nov 2007
Boat: Mainship Pilot 30
Location: Corinth
Posts: 3,112
yeah i knew it was something weak like that. the 4x100 is to the tower.
__________________
"if one day the speed kills me, do not cry because i was smiling." -Paul Walker
Reply With Quote
  #16  
Old 06-17-2013, 08:33 PM
hughes26 hughes26 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2013 X-30 6.0L
Location: Southeast
Posts: 31
From JL's website on the 700/5 amp - 75 W x 4 @ 4 Ω, while also delivering a stout 300 W of power to a subwoofer system
Reply With Quote
  #17  
Old 06-17-2013, 08:46 PM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,076
We should upgrade both amps!

My next boat I'm going to delete the stereo system completely and go wetsounds. I'll probably even save money too. I just love the stock look, especially those aluminum cans.
Reply With Quote
  #18  
Old 06-17-2013, 08:51 PM
hughes26 hughes26 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2013 X-30 6.0L
Location: Southeast
Posts: 31
I agree about the cans. The stock alum cans look better than any other option to put up there.

My opinion is that I paid for the Ferrari of boats. I should not have to tweak or change anything to make it better. For the money I paid for my boat it should have come off the assembly line with everything perfect. How much more would it really cost MC to upgrade the amp's to the right ones?
Reply With Quote
  #19  
Old 06-17-2013, 11:49 PM
MLA MLA is offline
TT Enthusiast
 
Join Date: May 2012
Boat: pontoon
Location: Lake Wylie Area
Posts: 272
Quote:
Originally Posted by hughes26 View Post
I just picked up my new X-30. Love the boat but not to happy with the factory sound from the tower. I have 4 tower speakers on the tower, Clarion Head unit, JL Speakers and JL amps.

The audio in the boat sounds great but the audio from the tower speakers does not. Seems to have a distorted sound. Dealer said the tower amp was on high pass so they changed it to full pass. It did not seem to help.

Any thoughts?
Your dealer is backwards. Amp should be in Hi-Pass for the towers. The frequency should be in the 80Hz range. They could maybe go lower, but 80Hz is a good starting point for the 7.7. Running on full-pass would actually explain some distortion at the upper volume levels. If its a 4chnl amp, there are settings for both halves of the amp. A set for chnls 1 and 2 and then for 3 and 4. Make sure they are mirrored.
Reply With Quote
  #20  
Old 06-17-2013, 11:53 PM
treiter's Avatar
treiter treiter is offline
TT Newbie
 
Join Date: Mar 2012
Boat: 2009 X-15
Location: Alberta
Posts: 104
I agree with Aric. I just installed the MHD-750/1 and my 7.7's scream compared to the underpowered factory set up.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:19 AM.