Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-10-2013, 02:01 AM
PremierPOWER PremierPOWER is offline
TT Newbie
 
Join Date: Aug 2013
Boat: Lots
Location: Midwest
Posts: 20
X Star Starting issue, possibly fuel pump

Well long story short, we ran the boat all week while tuning the speakers and t started and ran fine every time. Towed it 5 hours down to lake Cumberland today and it started for 5-10 sec and now nothing (seems it just burned the fuel in the lines up). We took the valve stem cap off And pushed on the stem to see if fuel was coming out (could hear the fuel pump on ignition, and verified no pump with kill switch pulled). It just cranks and cranks as if the kill switch is pulled but its not. I'm limited on tools and diagnosing equipment down here but I can't imagine what else it would be. Any suggestions as we are trying to make an event tomorrow.
__________________
- 1996 Donzi 22 Classic Blackhawk Limited Edition w/ 500hp Mercruiser 502
- 2001 Sea-Ray 240 Sundeck w/ Mercruiser 5.0L
- 2005 Formula 382 FasTECH w/ Twin Mercury Racing HP600SCi
- 2008 Donzi 43 ZR w/ Triple Mercury Racing HP700SCi
- 2009 Meridian 441 Sedan Bridge w/ Twin Mercruiser Cummins 480
- 2014 Regal 27 FasDeck RX w/ Mercruiser 8.2 Mag
Reply With Quote
  #2  
Old 08-10-2013, 06:46 AM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,412
So,was there fuel pressure when you pushed on the schraeder valve...
If no fuel,the first suspect ,as usual,is the fuel pump.
Read the -Fuel pump 101- thread.
Good luck!
__________________
Keep skiing!!!
Reply With Quote
  #3  
Old 08-10-2013, 07:36 AM
PremierPOWER PremierPOWER is offline
TT Newbie
 
Join Date: Aug 2013
Boat: Lots
Location: Midwest
Posts: 20
Whoops forgot to write in that no fuel when I pushed the Schrader valve. I'm trying to find a compatible 60psi fuel pump from napa or auto store since no dealers anywhere close
__________________
- 1996 Donzi 22 Classic Blackhawk Limited Edition w/ 500hp Mercruiser 502
- 2001 Sea-Ray 240 Sundeck w/ Mercruiser 5.0L
- 2005 Formula 382 FasTECH w/ Twin Mercury Racing HP600SCi
- 2008 Donzi 43 ZR w/ Triple Mercury Racing HP700SCi
- 2009 Meridian 441 Sedan Bridge w/ Twin Mercruiser Cummins 480
- 2014 Regal 27 FasDeck RX w/ Mercruiser 8.2 Mag
Reply With Quote
  #4  
Old 08-10-2013, 11:24 AM
Skyskiguy Skyskiguy is offline
TT Enthusiast
 
Join Date: May 2012
Boat: 2006 X30
Location: Utah
Posts: 250
Airtex E2044
Reply With Quote
  #5  
Old 08-10-2013, 05:03 PM
oumiller28's Avatar
oumiller28 oumiller28 is offline
TT Regular
 
Join Date: Aug 2007
Boat: MasterCraft, X-Star, 2007,
Location: West Coast
Posts: 95
I had the same issue with my 07 X-Star with just over 300 hours on it. I have seen people say just to replace the pump. After I pulled everything out I think I should replace the fuel filter too. Any thoughts or suggestions? I see replacement parts for the pump (airtex E2044) but nothing about the fuel filter. I have no clue where to get the replacement filter, other than ordering one from MC.
All help is greatly appreciated!!
Reply With Quote
  #6  
Old 08-11-2013, 05:01 PM
PremierPOWER PremierPOWER is offline
TT Newbie
 
Join Date: Aug 2013
Boat: Lots
Location: Midwest
Posts: 20
Got up early yesterday and the guy at auto zone cross referenced the airtex 2044 with the part numbers I found on the 101 thread. Got the pump installed in about 1/2 hr and boat ran great all day! Need to change the filter now but the original pump lasted 575 hrs
__________________
- 1996 Donzi 22 Classic Blackhawk Limited Edition w/ 500hp Mercruiser 502
- 2001 Sea-Ray 240 Sundeck w/ Mercruiser 5.0L
- 2005 Formula 382 FasTECH w/ Twin Mercury Racing HP600SCi
- 2008 Donzi 43 ZR w/ Triple Mercury Racing HP700SCi
- 2009 Meridian 441 Sedan Bridge w/ Twin Mercruiser Cummins 480
- 2014 Regal 27 FasDeck RX w/ Mercruiser 8.2 Mag
Reply With Quote
  #7  
Old 08-11-2013, 07:06 PM
mikeg205's Avatar
mikeg205 mikeg205 is online now
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,927
Send a message via Skype™ to mikeg205
Quote:
Originally Posted by PremierPOWER View Post
Got up early yesterday and the guy at auto zone cross referenced the airtex 2044 with the part numbers I found on the 101 thread. Got the pump installed in about 1/2 hr and boat ran great all day! Need to change the filter now but the original pump lasted 575 hrs
awesome!!!! Love reading the the quick reasonable fix!!!!
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #8  
Old 08-11-2013, 10:28 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,397
skidim sells the fuel filter.

Just curious, ever run your tank below 1/4 tank of fuel? If so, don't do that anymore. With little gas around the fuel pump it will run hot and fail early.
__________________
I was njskier on here.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:55 PM.