Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #11  
Old 06-20-2013, 03:57 PM
tommydbouy's Avatar
tommydbouy tommydbouy is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2009 X-15, MCX
Location: NE Ohio
Posts: 68
My 09 X-15 that I just got this spring has a similar sound at that rpm. When I got the boat I paid the local MC dealer (didn't buy the boat from him) to take us out on it for the first time to go over how everything works. He said that the noise was from the transmission and was normal. He said the noise is higher if the transmission has traditional ATF fluid in it or synthetic ATF. I got ahold of the Malibu dealer I got it from and it does have the synthetic ATF in it. The local MC dealer said the synthetic ATF won't hurt anything but after this season switch to the 15-W40 oil that MC calls for. It will help deaden the sound.
Reply With Quote
  #12  
Old 07-01-2013, 08:41 AM
Ripple's Avatar
Ripple Ripple is offline
TT Regular
 
Join Date: Apr 2013
Boat: 2014 X10 5.7 Ilmor
Location: Southeast
Posts: 71
Quote:
Originally Posted by treiter View Post
My 09 X-15 has done same thing since day 1. No worries.
Good to know.

Could not get too the belts and determine if they need to be replaced. What is the general rule of thumb on when you replace belts - after how many hours or years?
Reply With Quote
  #13  
Old 07-01-2013, 10:01 AM
GoneBoatN's Avatar
GoneBoatN GoneBoatN is offline
MC Devotee
 
Join Date: Oct 2010
Boat: 2010 X-15 w/MCX
Location: Nor Cal
Posts: 1,822
Put my MCX in the here too group.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:31 AM.