Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2013, 08:05 PM
Manciniat's Avatar
Manciniat Manciniat is offline
TT Regular
 
Join Date: Jul 2012
Boat: 05 x star
Location: Midwest
Posts: 46
05 x star tower issues

The piece that connects my board rack to the tower has broken.
My local dealer says that Mastercraft does not offer replacement parts because my tower is to old.....wth ?!?
Has anyone had this issue ?? If so, how did you fix this issue ??



Reply With Quote
  #2  
Old 06-10-2013, 08:26 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,397
I cannot tell what part of your rack that is in your pic, but you have ski racks on yours not board racks. Maybe you can replace your ski racks with board racks?

Name:  flag pic 5.jpg
Views: 200
Size:  77.1 KB

Not the best pic
__________________
I was njskier on here.
Reply With Quote
  #3  
Old 06-10-2013, 08:29 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,397
This pic is a little better

Name:  Palma and crew 2011.jpg
Views: 193
Size:  83.3 KB
__________________
I was njskier on here.
Reply With Quote
  #4  
Old 06-10-2013, 08:40 PM
Manciniat's Avatar
Manciniat Manciniat is offline
TT Regular
 
Join Date: Jul 2012
Boat: 05 x star
Location: Midwest
Posts: 46
It's the piece on the top side of the "ski rack".....Bolts to the main beam of the tower.

The original owner put the extensions on the rack, holds my boards really good for being a ski rack.
Reply With Quote
  #5  
Old 06-10-2013, 08:54 PM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,283
I still can't tell what part of your tower is broken. Take a photo zoomed out a bit more showing the entire part that is broken.
__________________
Tim
Gone, surfing.
Reply With Quote
  #6  
Old 06-10-2013, 08:55 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,397
Perhaps the bouncing/flexing of the boards on those racks caused that piece to crack?
Just a guess, also keep in mind 2 wakeboards weight more than 2 slalom skis. Plus boards have a lot more rocker than skis, so maybe there is too much pressure on the rack since the fingers are so far apart.
__________________
I was njskier on here.
Reply With Quote
  #7  
Old 06-10-2013, 09:58 PM
Manciniat's Avatar
Manciniat Manciniat is offline
TT Regular
 
Join Date: Jul 2012
Boat: 05 x star
Location: Midwest
Posts: 46


It is this piece....the top of it...the part of it that goes inside the block that is welded to the tower and two bolts go thru...it's cracked thru those bolt holes.
Reply With Quote
  #8  
Old 06-10-2013, 10:03 PM
Manciniat's Avatar
Manciniat Manciniat is offline
TT Regular
 
Join Date: Jul 2012
Boat: 05 x star
Location: Midwest
Posts: 46
I don't see it being a weight issue...it is a structural piece of the tower. Two boards hanging on the tower is just that, Two boards....no matter what is holding them, same weight correct ?

I'm trying to find a fix for this issue or some opinions on it, not get schooled on my ski rack !!
Reply With Quote
  #9  
Old 06-10-2013, 10:05 PM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,283
So it's the upper mount arm that crack? Have you called MasterCraft By Design? I'm not sure if they were making the towers back then.

If they don't have the CAD for it I'm sure someone could spool gun a weld on it.
__________________
Tim
Gone, surfing.
Reply With Quote
  #10  
Old 06-10-2013, 10:18 PM
Manciniat's Avatar
Manciniat Manciniat is offline
TT Regular
 
Join Date: Jul 2012
Boat: 05 x star
Location: Midwest
Posts: 46
Yeah I'm looking into getting it welded. Just thought I'd see if this has happened to anyone else in the past or if it's a isolated issue.
I would like to switch to the newer style arms but the mounts are different I believe.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:55 PM.