Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #131  
Old 06-18-2013, 08:17 PM
svxwilson svxwilson is offline
TT Enthusiast
 
Join Date: May 2013
Boat: Ski Brendella, Super Comp, 1991, 351 Windsor
Location: Montana
Posts: 203
My mechanic (Frank) had some worries about the way they shipped the engine. It appeared as if it tipped over in the truck or who really knows(FedEx). There was a obvious amount of visible saw dust inside of the top of the heads by the valve springs. My mechanic (Frank) called the engine builders about it and they assured him it would be ok....
He installed it and it is acting like there is a valve problem. Frank is probably working on it right now. I will talk with Frank either later tonight or tomorrow morning as to what he found as a resolution between the builder and him. Sucks getting stuck with a warranty problem without ever even hitting the H2O.

Last edited by svxwilson; 06-18-2013 at 08:27 PM. Reason: Typo
Reply With Quote
  #132  
Old 06-19-2013, 05:45 PM
svxwilson svxwilson is offline
TT Enthusiast
 
Join Date: May 2013
Boat: Ski Brendella, Super Comp, 1991, 351 Windsor
Location: Montana
Posts: 203
Started a new thread with my new problems rather Than keep this old one alive. Thanks for everyone's help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:28 PM.