Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 06-03-2013, 11:18 AM
j4rowell's Avatar
j4rowell j4rowell is offline
TT Enthusiast
 
Join Date: Feb 2011
Boat: Row Boat w/ 5HP Motor for tubing
Location: The Moon
Posts: 138
2009 X2 - 350 MCX Power Loss & High Idle

I'm in need of some help.

When the boat is under load (ie surfing/wakeboarding) the engine will cut out every so often. The boat will not stall, but just return to an idle. After shutting the boat off for about 3 -5 minutes it seems to run fine for a bit but will eventually happen again.

Another issue I am having which I'm hoping is related, is sometimes the boat will idle high/rough.

Any suggestions?
Reply With Quote
  #2  
Old 06-03-2013, 11:21 AM
snork snork is offline
MC Devotee
 
Join Date: Jul 2007
Boat: 07 xstar
Location: south
Posts: 1,861
how many hrs?
Reply With Quote
  #3  
Old 06-03-2013, 11:34 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,495
Quote:
Originally Posted by j4rowell View Post
I'm in need of some help.

When the boat is under load (ie surfing/wakeboarding) the engine will cut out every so often. The boat will not stall, but just return to an idle. After shutting the boat off for about 3 -5 minutes it seems to run fine for a bit but will eventually happen again.

Another issue I am having which I'm hoping is related, is sometimes the boat will idle high/rough.

Any suggestions?
When it idles back down are you getting a buzzer and a check engine on the screen? Is your oil level low?
__________________
Tim
Gone, surfing.
Reply With Quote
  #4  
Old 06-03-2013, 11:43 AM
j4rowell's Avatar
j4rowell j4rowell is offline
TT Enthusiast
 
Join Date: Feb 2011
Boat: Row Boat w/ 5HP Motor for tubing
Location: The Moon
Posts: 138
Quote:
Originally Posted by snork View Post
how many hrs?
394 Hours

Quote:
Originally Posted by CantRepeat View Post
When it idles back down are you getting a buzzer and a check engine on the screen? Is your oil level low?
I am getting a "Check Engine" screen when the power cuts out but when the idle issue happens there is no "Check Engine" screen.

Thanks for the questions guys! Keep them coming!
Reply With Quote
  #5  
Old 06-03-2013, 11:43 AM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,412
Assuming the oil level and oil pressure are good, and the boat is not overheating, the next thing to check is fuel pressure. If you can check it when it loses power that would be best.

Sounds like your fuel pump is failing when it gets hot, then you shut it off for a bit and it cools down enough to start working again. Don't let your fuel tank go below 1/4 ever.
__________________
I was njskier on here.
Reply With Quote
  #6  
Old 06-03-2013, 11:46 AM
j4rowell's Avatar
j4rowell j4rowell is offline
TT Enthusiast
 
Join Date: Feb 2011
Boat: Row Boat w/ 5HP Motor for tubing
Location: The Moon
Posts: 138
Quote:
Originally Posted by Jerseydave View Post
Assuming the oil level and oil pressure are good, and the boat is not overheating, the next thing to check is fuel pressure. If you can check it when it loses power that would be best.

Sounds like your fuel pump is failing when it gets hot, then you shut it off for a bit and it cools down enough to start working again. Don't let your fuel tank go below 1/4 ever.
Would the fuel pump be related to the idle issue?
Reply With Quote
  #7  
Old 06-03-2013, 12:04 PM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,495
Quote:
Originally Posted by j4rowell View Post
Would the fuel pump be related to the idle issue?
Yes fuel pump/low pressure could result in a poor idle. It's a pretty easy check.

http://www.napaonline.com/Catalog/Ca...336_0361126168

The issue with your boat, MEFI 5 ECM, is you will need a semi expensive scan tool or PC software and cable to pull the codes from it.
__________________
Tim
Gone, surfing.
Reply With Quote
  #8  
Old 06-03-2013, 12:16 PM
j4rowell's Avatar
j4rowell j4rowell is offline
TT Enthusiast
 
Join Date: Feb 2011
Boat: Row Boat w/ 5HP Motor for tubing
Location: The Moon
Posts: 138
Quote:
Originally Posted by CantRepeat View Post
Yes fuel pump/low pressure could result in a poor idle. It's a pretty easy check.

http://www.napaonline.com/Catalog/Ca...336_0361126168

The issue with your boat, MEFI 5 ECM, is you will need a semi expensive scan tool or PC software and cable to pull the codes from it.
Great. I'll check the pressure. What's the operating range for this pump?

Can someone supply a cross reference number to the fuel pump for my motor so I can purchase from the local auto parts store (ie NAPA, AutoZone, Advance Auto, O'Reily's or Pep Boys)?
Reply With Quote
  #9  
Old 06-03-2013, 12:48 PM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,495
Quote:
Originally Posted by j4rowell View Post
Great. I'll check the pressure. What's the operating range for this pump?

Can someone supply a cross reference number to the fuel pump for my motor so I can purchase from the local auto parts store (ie NAPA, AutoZone, Advance Auto, O'Reily's or Pep Boys)?
Fuel pressure should be between 55-62 from idle to WOT.

A couple of threads about fuel pumps.

http://www.mastercraft.com/teamtalk/...ad.php?t=24965

http://www.mastercraft.com/teamtalk/...ad.php?t=25783
__________________
Tim
Gone, surfing.
Reply With Quote
  #10  
Old 06-05-2013, 11:53 PM
Seano Seano is offline
TT Regular
 
Join Date: Jun 2009
Boat: 2014 X30 GEN2
Location: Canada, Alberta
Posts: 83
check for exhaust manifold elbow sensor update for the 2008's. I had many issues with these #$%# sensors. Perhaps your 2009 was a 2008 engine. Basically the sensors are deleted for emission as they are faulty unless you live in California off course. My boat went into limp mode at a governed rpm. I did not have the idling RPM issue. good luck
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:47 PM.