Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Thread Tools Display Modes
Old 06-22-2013, 01:06 PM
12danielm 12danielm is offline
TT Newbie
Join Date: May 2013
Boat: 1995 mastercraft prostar
Location: east
Posts: 3
Gauges going crazy

I have a 2005 x-2 I went to reset the clock, and then all of the gauges starting going crazy. i turn on the engine, and the engine is running normal, but the gauges are all going from zero to full and back to zero? I dont know what to do.
Reply With Quote
Old 06-29-2013, 01:55 AM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
Join Date: Mar 2007
Boat: Nautique
Location: Midwest, Chicago
Posts: 2,271
Just saw this. Did you ever get it fixed? Sounds like a bad MMDC. That's first thing it does when it gets water inside it from a winter freeze. They are very fragile. You can run the boat fine without it for the time being , just unplug the MMDC connection and all your gauges will fall to rest. You perfect pass should still work because its not linked to the MMDC

2000 Mastercraft Xstar
2004,2005 Ski Centurion Avalanche C4
2003, Ski Centurion Cyclone
99,2000,2001, 2002 Ski Centurion Elite V/Hurricane/lightning
88 2001 Nautique
Reply With Quote
Old 06-29-2013, 10:05 AM
Flatwaterfooter Flatwaterfooter is offline
TT Enthusiast
Join Date: Jun 2005
Boat: 2006 PS 197
Location: NH
Posts: 379
Seems like the mmdc fail a lot. Should they just be removed in the winter?
Reply With Quote
Old 06-29-2013, 11:54 AM
mikeg205's Avatar
mikeg205 mikeg205 is online now
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 13,927
Send a message via Skype™ to mikeg205
Read alot of issues with the MDC here. Might be a bad ground on the MMDC ... since it's still showing signs of life... maybe contact points need cleaning up as well. Does the 2005 have any water sent to it via any tube? Are they sealed well? can condensation get in there? No help here but curious.
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
Old 07-06-2013, 11:38 PM
LittleFuss LittleFuss is offline
TT Enthusiast
Join Date: Mar 2012
Boat: 2004 X-30
Location: Louisiana
Posts: 241
I have an 04 MS 230. during my last few outings at what I can so far determine to be random times all my gauges except for the tach reset as if I had just turned the key on. where the needles jiggle and go to full then back to 0 then start functioning normally. then they do it again later at some other random time.

Anybody experience this?
2004 MariStar 230 VRS with X Package
Come find us on 'da Bayou
Reply With Quote
Old 07-08-2013, 03:27 PM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,082
LittleFuss, I recently replaced my tach for the same issue.
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -4. The time now is 10:19 AM.