Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2013, 12:06 PM
12danielm 12danielm is offline
TT Newbie
 
Join Date: May 2013
Boat: 1995 mastercraft prostar
Location: east
Posts: 3
Gauges going crazy

I have a 2005 x-2 I went to reset the clock, and then all of the gauges starting going crazy. i turn on the engine, and the engine is running normal, but the gauges are all going from zero to full and back to zero? I dont know what to do.
Reply With Quote
  #2  
Old 06-29-2013, 12:55 AM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,775
Just saw this. Did you ever get it fixed? Sounds like a bad MMDC. That's first thing it does when it gets water inside it from a winter freeze. They are very fragile. You can run the boat fine without it for the time being , just unplug the MMDC connection and all your gauges will fall to rest. You perfect pass should still work because its not linked to the MMDC
__________________
Current: 2008 Super Air 210TE

Previous : 2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop. 1200 hrs of flawless fun
Reply With Quote
  #3  
Old 06-29-2013, 09:05 AM
Flatwaterfooter Flatwaterfooter is offline
TT Enthusiast
 
Join Date: Jun 2005
Boat: 2006 PS 197
Location: NH
Posts: 377
Seems like the mmdc fail a lot. Should they just be removed in the winter?
Reply With Quote
  #4  
Old 06-29-2013, 10:54 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 11,175
Send a message via Skype™ to mikeg205
Read alot of issues with the MDC here. Might be a bad ground on the MMDC ... since it's still showing signs of life... maybe contact points need cleaning up as well. Does the 2005 have any water sent to it via any tube? Are they sealed well? can condensation get in there? No help here but curious.
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #5  
Old 07-06-2013, 10:38 PM
LittleFuss LittleFuss is offline
TT Enthusiast
 
Join Date: Mar 2012
Boat: 2004 X-30
Location: Louisiana
Posts: 239
I have an 04 MS 230. during my last few outings at what I can so far determine to be random times all my gauges except for the tach reset as if I had just turned the key on. where the needles jiggle and go to full then back to 0 then start functioning normally. then they do it again later at some other random time.

Anybody experience this?
__________________
2004 MariStar 230 VRS with X Package
Come find us on 'da Bayou
Reply With Quote
  #6  
Old 07-08-2013, 02:27 PM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: At the lake or on the way to the lake!
Posts: 1,812
LittleFuss, I recently replaced my tach for the same issue.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:59 PM.