Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 05-26-2013, 09:04 AM
Kweisner's Avatar
Kweisner Kweisner is offline
MC Fanatic
 
Join Date: Oct 2012
Boat: 2007 Prostar 197
Location: Charlotte, NC
Posts: 678
Strange engine behavior

Boat is a 2007 PS197 TT w/MCX and MEFI5. Engine fired up perfectly yesterday at the ramp. Idled around to bring the engine up to water temp, and then applied throttle to head for our spot. Took it normally up to about 3,500 RPM. After maybe 15-20 seconds, got a Check Engine warning and then engine dropped RPMs but kept operating. Checked gauges--all normal. Checked engine--running and sounding fine. No leaking hoses, belt great, etc. Throttled back up and engine spun fine but would not go above 2850 RPMs, regardless of throttle position. This truly seemed to be as though the top end was being governed/limited, vs. any issue with fuel delivery or ignition, since there was no misfiring, etc.

Ran about 10 mins that way and decided to stop. Let the boat sit for an hour or so. Restarted and it operated as normal for the rest of the day, running up to 4600 at WOT, although we are getiing a check engine tone every now and then. Looking for any experience or thoughts on what I could check, or if this is something that a dealer needs to service.
__________________
"This one goes to eleven." 2007 ProStar 197 TT w/MCX and Powerslot.
Reply With Quote
  #2  
Old 05-26-2013, 09:31 AM
clrussell's Avatar
clrussell clrussell is online now
MC Maniac
 
Join Date: Jul 2012
Boat: None
Location: midwest
Posts: 4,625
Fuel pump getting weak?


Tapatalk
Reply With Quote
  #3  
Old 05-26-2013, 09:55 AM
Engine Nut's Avatar
Engine Nut Engine Nut is offline
TT Enthusiast
 
Join Date: Apr 2005
Location: TN
Posts: 316
What is the condition of your battery and/or battery and ground connections. 2007 Models had a low voltage alarm. If I remember correctly, if the voltage drops below 10.5V (usually happens during the crank/start cycle) it will set an alarm and put the engine into power reduction. The alarm should go away after after several start/warm up cycles with out a repeat of a low voltage event.
__________________
Engine Nut
Indmar Marine Engines
Power to the Sport
Reply With Quote
  #4  
Old 05-26-2013, 10:12 AM
Seano Seano is offline
TT Regular
 
Join Date: Jun 2009
Boat: 2014 X30 GEN2
Location: Canada, Alberta
Posts: 83
I have had this on my 08 x2 with mcx. Rpm was lower however, basically went into limp mode. Yours does sound related to fuel, I also agree with the battery check. Don't just test them for 12. Volts, get a draw test done on them, most battery places will do it it for free. Do you have the sensors on the elbows of your exhaust manifolds where it connects to the large rubber hose?
Reply With Quote
  #5  
Old 05-26-2013, 04:48 PM
Kweisner's Avatar
Kweisner Kweisner is offline
MC Fanatic
 
Join Date: Oct 2012
Boat: 2007 Prostar 197
Location: Charlotte, NC
Posts: 678
Thanks for the ideas guys--I will look into all of them. I've experienced limp mode due to a bad t'stat, and this was definitely not that. The rev limit was very consistent at 2850, meaning it didn't surge or sputter--just would not exceed that point. This makes me suspect it wasn't fuel related as i think a delivery problem would result in more erratic revs.

The low volt sounds more plausible although my connections are all pristine as I did the dual batt install w/Borg Warner auto isolation relay this winter. The house batt is a new Optima Bluetop and lives on a charger/maintainer while garaged. Could be the starting batt is aging as I don't know its lifecycle--came from PO. Sems that's the first and easiest thing to check.

These random and unrepeatable issues are the toughest and in my experience are usually rotted in the electrical system. Time to buy a second oar!
__________________
"This one goes to eleven." 2007 ProStar 197 TT w/MCX and Powerslot.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:12 PM.