Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Towers

Reply
 
Thread Tools Display Modes
  #11  
Old 05-16-2013, 12:44 PM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,245
Got out to the boat yesterday and was lucky enough to have two nuts of the correct thread to use to pull the threaded rod out. Worked like a champ. Put anti seize on the thread going into the aluminum and red Loctite on the thread going into the knob. Tried shimming the pin but the mount still wiggles. The MCOCD is kicking in on this but I can't seem to see a resolution that doesn't involve eliminating that joint.

Well at least I got everything back together.
Reply With Quote
  #12  
Old 05-16-2013, 01:10 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 10,963
Does your mirror have the two plastic "sleeves" that go in the hole where the two unthreaded studs go? That takes all the slop out. Let me see if I can find a pic.
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #13  
Old 05-16-2013, 09:10 PM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,245
When I pulled it apart I only saw one stud. Didn't notice a sleeve. I'll look when I get back to the boat. Everything should come apart easy now.
Reply With Quote
  #14  
Old 05-16-2013, 10:19 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 10,963
I am missing one, but this is what I am talking about...

Name:  ImageUploadedByTapatalk1368757138.450506.jpg
Views: 89
Size:  56.1 KB

Name:  ImageUploadedByTapatalk1368757170.167282.jpg
Views: 91
Size:  44.5 KB
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #15  
Old 05-17-2013, 09:14 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,092
I lost one too. Order 6 from Lex and when I put them back in I mix a little epoxy and dabbed a dot on the flat part before I put the sleeves in. So far it has held and I've not lost anymore of them.
__________________
Tim
Gone, surfing.
Reply With Quote
  #16  
Old 05-17-2013, 09:31 AM
2010Prostar197's Avatar
2010Prostar197 2010Prostar197 is offline
TT Enthusiast
 
Join Date: May 2009
Boat: 2010 Prostar 197
Location: East Central Illinois
Posts: 190
What place is Lex???

I have been looking for a spare also.

I just use medical tape taped over the area while the mirror is off to keep them from falling out
Reply With Quote
  #17  
Old 05-17-2013, 09:35 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,092
Quote:
Originally Posted by 2010Prostar197 View Post
What place is Lex???

I have been looking for a spare also.

I just use medical tape taped over the area while the mirror is off to keep them from falling out

Sorry, Lex @ Rambo marine.
__________________
Tim
Gone, surfing.
Reply With Quote
  #18  
Old 05-17-2013, 03:49 PM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,245
Wow I need to look at my mirror again. I'll take some pictures. I only saw one pin and no collar. Should my 07 mirror look like yours? If so that explains a lot.
Reply With Quote
  #19  
Old 05-17-2013, 04:40 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 10,963
Mine is an '07.... it should look the same, but who knows.
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #20  
Old 05-19-2013, 08:26 AM
davidstan's Avatar
davidstan davidstan is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: 2008 X2
Location: AL/GA
Posts: 562
Quote:
Originally Posted by davidstan View Post
Same thing happened to my knob. Will try the locktite route. Thought it was just me.
Tried the dab of locktite and it worked! Thx for the advice TT as usual a solution found on this site
__________________
David
2008 X2 MCX
1999 Maristar 210 (sold)
1996 Bayliner 2050
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:25 PM.