Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 05-07-2013, 11:15 AM
Stokey Stokey is offline
TT Newbie
 
Join Date: Feb 2013
Boat: Xstar
Location: North East
Posts: 20
2006 xstar faulty ballast gauges

New owner of 2006 xstar. I have three ballast gauges. One that works, one that is very jumpy, and one that doesnt work at all. I am thinking this has more to with the ballast float sensors then the actual gauge, but wanted to get some more experienced advice. Are these floats accessible with the standard ballast stock system? All ballasts do fill up and empty fine.
Reply With Quote
  #2  
Old 05-07-2013, 08:02 PM
snork snork is offline
MC Devotee
 
Join Date: Jul 2007
Boat: 07 xstar
Location: south
Posts: 1,657
adjustments screws are located under the access plate port and starboard just in front of the lounge seat and for the KGB you'll need to remove the portion of the floor in center of floor 4 screws
Reply With Quote
  #3  
Old 05-07-2013, 09:38 PM
Stokey Stokey is offline
TT Newbie
 
Join Date: Feb 2013
Boat: Xstar
Location: North East
Posts: 20
Thanks.I will take a look at those!! Hoepfully will find it an easy fix.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:39 AM.