Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #31  
Old 05-14-2013, 01:40 PM
Snipe's Avatar
Snipe Snipe is offline
MC Fanatic
 
Join Date: Nov 2012
Boat: 1998 ProStar 190
Location: Three Lakes,WI/summer;Menomonee Falls,WI/winter
Posts: 832
Quote:
Originally Posted by Footin View Post
I had the same problen a few years back, I chased the threads with a 3/4 NPT tap then installed 1/4 turn ball valves on each side. Now when I winterize I just turn the valves to drain, no more removing the plugs.
Pictures??
Reply With Quote
  #32  
Old 05-14-2013, 08:57 PM
Ski-me's Avatar
Ski-me Ski-me is offline
MC Devotee
 
Join Date: Mar 2007
Boat: Mastercraft, Prostar 205, 1994, LT1
Location: Rocky Mountains....Colorado Springs
Posts: 2,468
OK, got them uploaded finally!

I did find the tap at Ace but it was in a different packaging than the smaller one. We initially missed it but I went back and found it sitting on the bottom shelf rather than with all the others in a pretty display.













__________________
- Jeff

1994 205, LT1
Reply With Quote
  #33  
Old 05-14-2013, 11:37 PM
XtwentyNot's Avatar
XtwentyNot XtwentyNot is offline
TT Enthusiast
 
Join Date: Jul 2012
Boat: None
Location: Pacific Northwest
Posts: 275
Nicely done!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:25 AM.