Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 05-03-2013, 08:43 AM
h2oskifreak's Avatar
h2oskifreak h2oskifreak is offline
MC Devotee
 
Join Date: May 2007
Boat: 1994 PS 190 TBI
Location: West
Posts: 1,211
Fresh water pump for a 75 s n s

Thought my impellor housing was leaking. Turns out the fresh water pump is bad. Any suggestions on where to get one, and cost? Does it come with a kit w/ fresh impellor, or just replace it while I have it apart? 351Windsor motor.
__________________
"One foot in the grave, one foot on the pedal, I was born a rebel" Petty
Reply With Quote
  #2  
Old 05-03-2013, 09:15 AM
etduc's Avatar
etduc etduc is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: Mastercraft Prostar 205
Location: Looking for a windshield
Posts: 823
Quote:
Originally Posted by h2oskifreak View Post
Thought my impellor housing was leaking. Turns out the fresh water pump is bad. Any suggestions on where to get one, and cost? Does it come with a kit w/ fresh impellor, or just replace it while I have it apart? 351Windsor motor.
This help, http://www.ebasicpower.com/waterpumps/
__________________
Ayyyy!

1994 RED Mastercraft 205, Chevy 5.7 TBI.
Reply With Quote
  #3  
Old 05-03-2013, 10:16 AM
h2oskifreak's Avatar
h2oskifreak h2oskifreak is offline
MC Devotee
 
Join Date: May 2007
Boat: 1994 PS 190 TBI
Location: West
Posts: 1,211
Thank you. My mechanic is a car guy, so this will help us both.
__________________
"One foot in the grave, one foot on the pedal, I was born a rebel" Petty
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:39 AM.