Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Appearance

Reply
 
Thread Tools Display Modes
  #1  
Old 04-28-2013, 10:19 PM
96prostar190's Avatar
96prostar190 96prostar190 is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: In the hunt!
Location: California
Posts: 208
Driver seat mounts

Hey guys, so today I somehow broke the front two mounts on the drivers seat... I'm baffled. Not sure how it happened or if one was broken before and today I just finished it off or what. Anyways, has anyone had a problem like this? I'm changing the oil and doing other random stuff to it tomorrow too so I might as well fix this too! Any one have solid fixes? Thanks in advance for the help!
__________________
"Slingshot, engage"
Reply With Quote
  #2  
Old 04-29-2013, 08:26 PM
Miss Rita's Avatar
Miss Rita Miss Rita is offline
MC Fanatic
 
Join Date: Jul 2009
Boat: 1992 ProStar 205, 1991 Ski Pro
Location: Black Hills
Posts: 851
did you break the sliders, or did it break where the sliders bolt to the pedestal? If the sliders are broken then they are easily replaced by your friendly MC dealer, about $35.
Reply With Quote
  #3  
Old 04-29-2013, 09:29 PM
96prostar190's Avatar
96prostar190 96prostar190 is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: In the hunt!
Location: California
Posts: 208
Quote:
Originally Posted by Miss Rita View Post
did you break the sliders, or did it break where the sliders bolt to the pedestal? If the sliders are broken then they are easily replaced by your friendly MC dealer, about $35.
Sliders are good, It looks like however they bolt to the sliders is the problem. Also, how the eff do you take the seat off the sliders? I was messing around with it for 20 minutes today and couldn't figure it out... Man I feel dumb.
__________________
"Slingshot, engage"
Reply With Quote
  #4  
Old 04-30-2013, 10:20 AM
Dylan's Avatar
Dylan Dylan is offline
MC Fanatic
 
Join Date: Mar 2010
Boat: 2000 Wakesetter VLX
Location: San Diego, CA
Posts: 566
Quote:
Originally Posted by 96prostar190 View Post
Sliders are good, It looks like however they bolt to the sliders is the problem. Also, how the eff do you take the seat off the sliders? I was messing around with it for 20 minutes today and couldn't figure it out... Man I feel dumb.
Sounds like you pulled the bolts through the fiberglass base as Miss Rita suggested.

To remove:
Pull up your seat base, and you should have access to the holes by moving the seat. Off my memory, slide the seat all the way back removing the front two bolts. Then look at the two holes in the back, at the bottom of the backrest. Slide the seat forwards until you see the bolts, and remove.
Reply With Quote
  #5  
Old 04-30-2013, 12:58 PM
96prostar190's Avatar
96prostar190 96prostar190 is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: In the hunt!
Location: California
Posts: 208
Thanks for the help, I'll post pics of what I'm dealing with later today.
__________________
"Slingshot, engage"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:40 PM.