Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 04-24-2013, 09:29 AM
TNstevo TNstevo is offline
TT Newbie
 
Join Date: Apr 2013
Boat: 2003 x2 mcx
Location: Southeast
Posts: 18
Fix for speedo on 03 x2.

Anyone have links/ideas for fixing speedo o. 03 x2 with mcx engine? Also has perfect pass.
On my old Tristar you just had to unclog the probes at the back of the boat, but I don't see any on the x2? Thanks in advance!
Reply With Quote
  #2  
Old 04-24-2013, 09:55 AM
Kevin@MWMC's Avatar
Kevin@MWMC Kevin@MWMC is offline
TT Enthusiast
 
Join Date: Jun 2009
Boat: 2014 MasterCraft X30
Location: Twin Cities, MN
Posts: 289
Quote:
Originally Posted by TNstevo View Post
Anyone have links/ideas for fixing speedo o. 03 x2 with mcx engine? Also has perfect pass.
On my old Tristar you just had to unclog the probes at the back of the boat, but I don't see any on the x2? Thanks in advance!
There should be a paddle wheel under the boat. Check that out and make sure it is not stuck or broken.
Reply With Quote
  #3  
Old 04-24-2013, 12:15 PM
46Chief 46Chief is offline
TT Enthusiast
 
Join Date: Jan 2011
Boat: 2002 Prostar 209 "Tarbaby", 2001 Prostar 190 Donor "Holestar"
Location: MidAtlantic
Posts: 288
Just saw this, probably what you are looking for.

http://www.mastercraft.com/teamtalk/...917#post927917
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:35 PM.