Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 04-07-2013, 12:10 PM
mseller mseller is offline
TT Enthusiast
 
Join Date: May 2011
Boat: 2008 X45
Location: South Carolina
Posts: 212
Ballast sensor problem

I have an 08 X45 and yesterday with the ballast switches OFF and tanks empty the right rear ballast sensor burned up. I unplugged the sensor to stop any further damage and continued riding. An hour or so later the left sensor started smoking and burned up as well. At this point I unplugged the left as well as the center ballast sensor to try to salvage the last sensor.

Has anyone ever experienced this issue before ? I hesitate to replace the sensor not knowing what caused the problem to begin with. Any help would be greatly appreciated.

Thanks in advance
Reply With Quote
  #2  
Old 04-07-2013, 12:30 PM
Traxx822's Avatar
Traxx822 Traxx822 is online now
MC Devotee
 
Join Date: Jul 2012
Boat: Mastercraft, Maristar 200VRS, 1995, Indimar 5.7, My first MasterCraft
Location: Chicago SW sub
Posts: 2,484
It actually got hot? That's scary.
__________________
When I was a child, I used to talk as a child, think as a child, reason as a child; when I became a man, I put aside childish things.
1 Corinthians Chapter 13 - 11
Reply With Quote
  #3  
Old 04-28-2013, 07:22 PM
oliver00 oliver00 is offline
TT Newbie
 
Join Date: Aug 2012
Boat: Mastercraft,X-Star,2008,6.0
Location: Midwest
Posts: 13
Both rear tank sensors in my 08 star were burnt when I got our boat. I asked the previous owner and he claimed to not know. I just installed new ones @ $30 or $35 each. They work fine now but the old ones looked bad.
Reply With Quote
  #4  
Old 05-20-2013, 03:58 PM
mseller mseller is offline
TT Enthusiast
 
Join Date: May 2011
Boat: 2008 X45
Location: South Carolina
Posts: 212
can you get these online or did you go through mastercraft?
Reply With Quote
  #5  
Old 05-20-2013, 05:56 PM
oliver00 oliver00 is offline
TT Newbie
 
Join Date: Aug 2012
Boat: Mastercraft,X-Star,2008,6.0
Location: Midwest
Posts: 13
The dealer
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:01 PM.