Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 02-22-2013, 05:16 PM
XStar08's Avatar
XStar08 XStar08 is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft XStar, 08, LY6; MasterCraft ProStar 190, 91, Ford Mustang;
Location: Central Europe
Posts: 196
Post 2008 X Star ballast upgrade

Ok so I finally ordered all the components to upgrade the internal ballast of my 2008 X Star.

I would like to post some hints as well as pics as I go trough the process of installing the ballast upgrade. Firstly I wanted to say a big thank you to Spencer from WakeMakers.com who helped me with answering a lot of questions (I guess I sent him over at least 10 e-mails and all of them have been answered very fast and with helpfull information).

I started with having in mind that I'm going to add the Fly High Pro Ballast System which you can buy for example with wakemakers. During the process of nailing down what I really want and need as well as optimizing the components I would need (to get the weight down to reduce shipping costs, to enhance the flow of water in the system, and so on) I realized that the above mentioned system is not exactly what I wanted.

I wanted not to use the T hose barb fittings but the wye fittings to optimize the flow of the water. I also realized that buying the custom made rear bags instead of the standard Fly High rear bags I would spend more money and get less possible weight (720lbs versus 750lbs).

Another thing importent for me was to make sure that by filling only the bags and not the rear tanks water overflowing the bags (vent line) will not be allowed to go backwards to the (empty) tanks but is forced to go out of the boat. I therefore decided to not only use the T assembly stop valves but to go with two check valves on each side of the Y which is bringing together the vent lines of the bag/hard tank.

Beside that I mostly went with what you get also by buying the system. Well, one major issue for me was to reduce the weight of the package which has/had to be shipped as much as possible since it would have to be shipped to Europe. I therefore decided to go green and buy the hose with a local store. By doing this I am also able to get some more hose in case I'm running out of it during installation.

So to get started I placed my order with WakeMakers today. I ordered the following components:
- 2x Fly High Pro X Series Fat Sac
- 2x Fly High Pro X MC X-Star Bow Sac
- 6x Hose Barb Wye Fitting
- 6x Inline Check Valve Fitting
- 8x Flow Rite Elbow Quick Release Connector W746
- 8x Flow Rite Straight Quick Release Connector W741
- 6x Fly High Ballast Bag Plug W731
- 3x Fly High Distribution Flow Mainfold
- 8x Flow Rite Quick Release Connect W743
- 30x Hose Clamps (even if I could get them also from a local store but there was no difference in shipping costs)

To be prepared once the stuff arrives I already bought some 1'' hose, I started with 20 meters which is about 65ft. I also started to build a plattform to have the pumps mounted horizontally instead of vertically (inside the transom) as it is stock. The main goal here is to be able to change the impellers comfortabely. Pictures will follow by tomorrow and I will try to keep you updated regarding the upgrade process.
Reply With Quote
  #2  
Old 02-22-2013, 05:54 PM
spencerwm spencerwm is offline
TT Newbie
 
Join Date: Mar 2009
Boat: MasteCraft ProStar 190 (Ford 351)
Location: Bend Or
Posts: 14
You are very welcome. I am excited to see how it all goes in. Thanks for mentioning Wakemakers and enjoy your star.
Reply With Quote
  #3  
Old 02-22-2013, 11:04 PM
sand2snow22's Avatar
sand2snow22 sand2snow22 is offline
MC Maniac
 
Join Date: Aug 2005
Boat: MC
Location: p-town
Posts: 3,816
Quote:
Originally Posted by spencerwm View Post
You are very welcome. I am excited to see how it all goes in. Thanks for mentioning Wakemakers and enjoy your star.
Spencer, please call Pat so we can pay and get the parts for our X-Star, too. Our buyer sent wire today! You feeling better?
Reply With Quote
  #4  
Old 02-23-2013, 04:53 PM
XStar08's Avatar
XStar08 XStar08 is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft XStar, 08, LY6; MasterCraft ProStar 190, 91, Ford Mustang;
Location: Central Europe
Posts: 196
So today I had some time to prepare the boat for the install. I removed the rear sundeck as well as all the stuff around the engine to have access to where the pumps should be mounted.

Firstly I planned to mount the pumps above the silent master horizontally. I therefore let build two supports made from aluminum to be mounted at the transom where the pumps are mounted originally. As the transom is not a flat surface and as the mounting points laminated to the transom are not levelled out (it looks as a the guy who laminated was drunk) it would not turn out as I planned. Picture shows the two supports but not the tray where the pumps would be mounted to.
Attached Images
 
Reply With Quote
  #5  
Old 02-23-2013, 05:10 PM
XStar08's Avatar
XStar08 XStar08 is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft XStar, 08, LY6; MasterCraft ProStar 190, 91, Ford Mustang;
Location: Central Europe
Posts: 196
Instead of building something above the silent master I decided to build it simpel by just putting a tray under the silent master.

Picture shows a wooden template.
Attached Images
 
Reply With Quote
  #6  
Old 02-23-2013, 07:29 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,429
Just curious, why are you moving your 3 pumps? Or are you adding more pumps?

I currently have (2) 400# sacs in the rear lockers, but thinking about getting the 720# x-star sacs instead. I tried a 750# sac in there but it's kinda long....hits my heater and won't fill up all the way.
I don't use the rear hard tank at all BTW.
__________________
I was njskier on here.
Reply With Quote
  #7  
Old 02-24-2013, 03:22 AM
XStar08's Avatar
XStar08 XStar08 is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft XStar, 08, LY6; MasterCraft ProStar 190, 91, Ford Mustang;
Location: Central Europe
Posts: 196
I'm moving the pumps because they are not accessible as they have been mounted.
I choose to go with the 750 bags because they are cheaper and I don't want to fill them completely so that they are able to adapt to the place they have.

Probably I'll add anothet pump to be used as a p&p system, but not for this season.
Reply With Quote
  #8  
Old 02-24-2013, 07:25 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,622
I would suggest that you find a different location that will allow you to mount your pumps with the impellers facing down. Mounting the pumps flat or upside down can lead to water leaking into the electrical motor and greatly reducing it's life. This happens when the little rubber washer/seal between the motor and the impeller housing goes bad. If that washer goes bad and the pumps are mounted with the impellers down you have a better chance of water not getting in the motors.

Likewise, with the motors that low in the bilge area you stand a good chance of them getting wet. This also presents the same issue as a leaky seal.

Either way, good luck with your install and +1 for wakemakers.com.
__________________
Tim
Gone, surfing.
Reply With Quote
  #9  
Old 02-24-2013, 08:24 AM
XStar08's Avatar
XStar08 XStar08 is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft XStar, 08, LY6; MasterCraft ProStar 190, 91, Ford Mustang;
Location: Central Europe
Posts: 196
Good point, I'll think about that. However if there is that much of water down there than something is wrong anyway. Wait! what if there is someone not used/skilled enough to handle to low freeboard of the star...
Reply With Quote
  #10  
Old 03-01-2013, 03:18 PM
XStar08's Avatar
XStar08 XStar08 is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft XStar, 08, LY6; MasterCraft ProStar 190, 91, Ford Mustang;
Location: Central Europe
Posts: 196
So yesterday I started getting the beast in there...
Attached Images
 

Last edited by XStar08; 03-01-2013 at 03:34 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:28 PM.