Go Back   TeamTalk > Classifieds Buy/Sell > For Sale: Parts & Accessories

Reply
 
Thread Tools Display Modes
  #81  
Old 03-26-2014, 05:57 PM
jdeml jdeml is offline
TT Enthusiast
 
Join Date: Jan 2011
Boat: 2004 Xstar
Location: North Texas
Posts: 264
Quote:
Originally Posted by David Analog View Post
Check in with Earmark Marine on these. Here's why. The Pro80 and Pro60 rings need to be unique in that they cannot space out the HLCD driver so that the motor structure is pulled out of the internal cradle. Without this support the heavy driver is dependent on only four #8 screws into ABS plastic. And with the shock of a towboat, a loose driver could seriously injure someone...maybe critically. The Earmark rings, for this reason, are approved by Wetsounds.
The Earmark Pro80/60 custom rings are 0.75" thick, rabbeted, and shine light from both the inside and outside of the diffuser ring, which is unique to this ring.
Yeah I spoke to Earmark and their groove doesn't fit my LED strip as I have my own (UV Purple) and their LEDs are attached inside. No biggie just thought Id ask before I fab up some myself. Thought Id got he easy route and save some time. Guess Ill cut some this weekend. Thanks!
Reply With Quote
  #82  
Old 03-26-2014, 05:59 PM
sgoyal's Avatar
sgoyal sgoyal is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: SeaDoo 2011
Location: GA
Posts: 265
Scott, Thanks for the picture and I'd steal the picture and put on my website with your final approval. Thanks for sharing.
__________________
SeaDoo Challenger 180SE
Blast LED (discounts available - send me PM for discount)
Reply With Quote
  #83  
Old 03-26-2014, 06:22 PM
sgoyal's Avatar
sgoyal sgoyal is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: SeaDoo 2011
Location: GA
Posts: 265
Cain, I sent you a message. I was out of town last week and just came back. please let me know if you want to speak over the phone.

Thanks,
__________________
SeaDoo Challenger 180SE
Blast LED (discounts available - send me PM for discount)
Reply With Quote
  #84  
Old 03-26-2014, 08:42 PM
MLA MLA is offline
TT Enthusiast
 
Join Date: May 2012
Boat: pontoon
Location: Lake Wylie Area
Posts: 428
Quote:
Originally Posted by Ironhorse View Post
Is there power at the tower speakers that you can use or do you have to run a power wire? If running new wire, is it a PITA?
Your 08 might just have an unused lighting circuit pre-wired from the factory. In most ive encountered, they use a common ground. You would have to fish these wires out of the tube.
Reply With Quote
  #85  
Old 03-27-2014, 09:19 AM
Ironhorse Ironhorse is offline
TT Enthusiast
 
Join Date: Apr 2010
Boat: 2008 Mastercraft X14 w/ LY6
Location: Alberta
Posts: 409
Thanks MLA.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:40 AM.