Go Back   TeamTalk > General MasterCraft Topics > Watersports > Wakesurfing

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2014, 06:52 PM
Cain0725 Cain0725 is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 2006. Mastercraft maristar
Location: South central
Posts: 367
2006 X30 Surf Setup Help

I run left side ballast full, 400 pound fat sack plumbed in on over fill. Fill center half to full and i still have to put my trim down 100 percent to get wash to go away. Doesn't seem right, i have tried speeds from 10 - 11 mph. Any thoughts from the experts,, i certainly need help.
Reply With Quote
  #2  
Old 06-22-2014, 07:06 PM
ap77's Avatar
ap77 ap77 is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: Mastercraft X2 2009 MCX
Location: Northwest
Posts: 276
Try it with no center ballast. You want to list the boat as much as possible. Another fat sac on the seat to list the boat if you don't have any human ballast.
__________________
Andrew
Reply With Quote
  #3  
Old 06-22-2014, 08:17 PM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,504
A quick, crappy, cell phone video of my 06 X30.

https://www.youtube.com/watch?v=Y5hwRwS6RBo

You can see my build here.

http://www.mastercraft.com/teamtalk/...ad.php?t=40934

The jist of it? You need more weight in the port rear and port side. Run your KGB full, but with more rear and port weight. Trim tab will always be 100% down to clean the wave up. All of my ballast is hidden and water weight. IE under the seats or in the lockers and no lead weight. 11.5 on the PP.

This video is with two people in the boat, my wife driving and my 17 year old daughter running the phone cam.

A clearer video but a rough water day. Too many wallys.

https://www.youtube.com/watch?v=70TF1zUOhlE

Oh, and no crazy wide angle lenses trying to make it look bigger then it really is!

I WAS IN THE POOL!
__________________
Tim
Gone, surfing.
Reply With Quote
  #4  
Old 06-24-2014, 01:25 AM
Cain0725 Cain0725 is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 2006. Mastercraft maristar
Location: South central
Posts: 367
so i need more than the 400 pounds fly high added on top of my ballast? What speed you all run? Main thing buddy kept saying i shouldn't have to use my trim tab, but otherwise the wake sucks and is complete white wash!
Reply With Quote
  #5  
Old 06-24-2014, 10:44 AM
CiscoStu's Avatar
CiscoStu CiscoStu is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2006 X-30, MCX
Location: S. Alberta, Canada
Posts: 132
I agree with what CantRepeat said... I have a 550 I put in the rear port locker, KGB to about 75%, port tank full, and trim tab all the way down. I do it by RPM on the M/C Cruise Control, I run about 2800 RPM. Usually translates to around 10-11.

If you have people, put them all on the port side seats or on the sundeck, and go to about 50% on the KGB.

Another BIG factor that most people don't consider is the depth of the water - it needs to be at least 20' deep, but deeper is better. In our lake, that's hard to find, but it does make a difference.
Reply With Quote
  #6  
Old 06-24-2014, 07:40 PM
Cain0725 Cain0725 is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 2006. Mastercraft maristar
Location: South central
Posts: 367
thanks everyone, i will try this weekend !
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:22 PM.