Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 09-07-2005, 04:39 AM
woody's Avatar
woody woody is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: 1/10th share in 2005 X2 and 2008 190
Location: Blighty
Posts: 105
Perfect Pass ^ button ceased functioning...

The up or ^ button on Perfect Pass has died. We're back to driving by throttle ugggg .

I'm assuming its the button thats gone and we need a new head unit, or whatever they're called, to slot into the dash. Or is this symptomatic of something else in the system? We've checked all connections and everything seems to be fine.

Has anyone had this happen to them? If so what was the solution.

Many thanks for any tips yawl may have.

1997 190
PP v.6 (I think)
Reply With Quote
  #2  
Old 09-07-2005, 05:54 AM
sizzler's Avatar
sizzler sizzler is offline
MC Maniac
 
Join Date: Aug 2004
Boat: 1995 barefoot200;;;2004 X9 MCX
Location: london,england:N51:33:37,E0:15:04
Posts: 2,669
might do better sending a pm to MYMC or JIM@BAWS
__________________
KEEP YA TOES UP!!!!!

2004 X9 MCX ALL BLACK


http://www.prwb.net/tallington/index.php?id=12


nice older x-boat at berth in the advertisment above
Reply With Quote
  #3  
Old 09-07-2005, 06:28 AM
woody's Avatar
woody woody is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: 1/10th share in 2005 X2 and 2008 190
Location: Blighty
Posts: 105
cheers sizzler
Reply With Quote
  #4  
Old 09-07-2005, 09:11 AM
G-man's Avatar
G-man G-man is offline
MC Devotee
 
Join Date: Jul 2004
Boat: SN 196 previous 93 stars&stripes 190 red
Location: TX
Posts: 1,529
Give a call to perfect pass and tell them what it isn't doing. sounds like display has a bad switch.
__________________
06 AWSA Approved Towboat
Reply With Quote
  #5  
Old 09-07-2005, 09:12 AM
Ric's Avatar
Ric Ric is offline
MC Master Poster
 
Join Date: Aug 2004
Boat: 2005 Prostar 197 / MCX
Location: _______Wastebasket_________________________
Posts: 13,209
Bummer
Look at the bright side, when you order the new gage, you can get the multi line display
__________________
Quote:
Originally Posted by TX.X-30 fan
Say yes to cheap beer---- no to ethanol.
Reply With Quote
  #6  
Old 09-07-2005, 09:57 AM
Mag_Red's Avatar
Mag_Red Mag_Red is offline
MC Addict
 
Join Date: Aug 2004
Boat: 2004 Prostar 209
Location: Cincinnati, Ohio
Posts: 5,603
Quote:
Originally Posted by george
Give a call to perfect pass and tell them what it isn't doing. sounds like display has a bad switch.
I agree..call them. I was having problems with mine when I first had the boat and they sent a new control unit, no questions asked.
Reply With Quote
  #7  
Old 09-07-2005, 10:09 AM
woody's Avatar
woody woody is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: 1/10th share in 2005 X2 and 2008 190
Location: Blighty
Posts: 105
Quote:
Originally Posted by Mag_Red
I agree..call them. I was having problems with mine when I first had the boat and they sent a new control unit, no questions asked.
Cheers guys I'll give that a whirl. Hopefully PP are as hot on customer service this side of the Altantic as yours.

Got to admit that multi line display does look sweet.
Reply With Quote
  #8  
Old 09-07-2005, 10:40 AM
erkoehler's Avatar
erkoehler erkoehler is offline
MC Master Poster
 
Join Date: Aug 2004
Boat: 2008 MasterCraft ProStar 197
Location: Bloomingdale, IL
Posts: 14,474
Send a message via AIM to erkoehler Send a message via MSN to erkoehler
Quote:
Originally Posted by woody
The up or ^ button on Perfect Pass has died. We're back to driving by throttle ugggg .

I'm assuming its the button thats gone and we need a new head unit, or whatever they're called, to slot into the dash. Or is this symptomatic of something else in the system? We've checked all connections and everything seems to be fine.

Has anyone had this happen to them? If so what was the solution.

Many thanks for any tips yawl may have.

1997 190
PP v.6 (I think)
Perfect opportunity for an upgrade to the new display!!!
__________________
www.lauderdalelakesmarina.com
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:55 PM.