Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #201  
Old 07-13-2013, 01:30 PM
EA2010 EA2010 is offline
TT Enthusiast
 
Join Date: Oct 2011
Boat: 2012 X-25
Location: Alberta, Canada
Posts: 191
I've got close to 40 hours on the water with the latest software. The system has been 100%.

Of course, that doesn't mean I am finished tweaking with additional ballast ... the work never ends!!!
Reply With Quote
  #202  
Old 07-13-2013, 01:40 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft x45 6.2L
Location: The South
Posts: 280
^^^same here. Everything on the software works great except I still have problems with the PnP ballast system
__________________
Reply With Quote
  #203  
Old 07-15-2013, 09:23 AM
CBRENT's Avatar
CBRENT CBRENT is offline
TT Enthusiast
 
Join Date: May 2010
Boat: 2012 X2
Location: Midwest
Posts: 285
So far so good with me as well! No issues.
Reply With Quote
  #204  
Old 01-22-2014, 06:06 PM
XstarOwnerND XstarOwnerND is offline
TT Newbie
 
Join Date: Jan 2014
Boat: Mastercraft, Xstar, 2013, 6.2
Location: North West
Posts: 2
In our '13 Xstar our Screens only work a few times to change the volume or the song on an ipod. This a crappy because you cant easily change a song and have to take eyes off the rider to change it. Our xstar is in our (soon not to be) dealer getting updates and has been for 5+ months. It is unacceptable. I have friends with a Tige and their screens with a different setup work like a charm. I think mastercraft sent these systems out a little early in my mind...
Reply With Quote
  #205  
Old 01-22-2014, 06:49 PM
Mastercraft13's Avatar
Mastercraft13 Mastercraft13 is offline
TT Enthusiast
 
Join Date: Sep 2012
Boat: 2013 X-10 6.0
Location: Columbus
Posts: 223
Quote:
Originally Posted by XstarOwnerND View Post
In our '13 Xstar our Screens only work a few times to change the volume or the song on an ipod. This a crappy because you cant easily change a song and have to take eyes off the rider to change it. Our xstar is in our (soon not to be) dealer getting updates and has been for 5+ months. It is unacceptable. I have friends with a Tige and their screens with a different setup work like a charm. I think mastercraft sent these systems out a little early in my mind...
Did you get your star early in the year? I know from my dealer that MC was working out a few software bugs throughout 2013. My only issue was a few screen freezes here and there, my dealer was honest and told me that the updates throughout the summer still had some bugs and told me to hold on. Late in the season my dealer installed the 2014 update and not having any issues.
Reply With Quote
  #206  
Old 03-06-2014, 06:54 PM
FoggyNogginz's Avatar
FoggyNogginz FoggyNogginz is offline
TT Enthusiast
 
Join Date: Aug 2006
Boat: 1998 PS205, then a 2002 X9, and now a 2012 X14V
Location: Center Hill Lake & Old Hickory
Posts: 365
Does anyone know how to check this software version? Also, what is the latest version?

Thanks in advance.
__________________
----------------------------------

"KC"

Cmon...lemme just push one button...
- Red X14V on Center Hill & Old Hickory lakes in TN -
Reply With Quote
  #207  
Old 03-06-2014, 07:06 PM
lentiman's Avatar
lentiman lentiman is offline
TT Enthusiast
 
Join Date: Sep 2011
Boat: 2012 MasterCraft X2
Location: Northwest
Posts: 132
http://www.mastercraft.com/teamtalk/...on+2012&page=5
Reply With Quote
  #208  
Old 03-15-2014, 08:01 PM
FoggyNogginz's Avatar
FoggyNogginz FoggyNogginz is offline
TT Enthusiast
 
Join Date: Aug 2006
Boat: 1998 PS205, then a 2002 X9, and now a 2012 X14V
Location: Center Hill Lake & Old Hickory
Posts: 365
Thanks! I just bought a 2012 and I'm coming up to speed on these issues. Mine water-tested just fine, but I guess you never know.
__________________
----------------------------------

"KC"

Cmon...lemme just push one button...
- Red X14V on Center Hill & Old Hickory lakes in TN -
Reply With Quote
  #209  
Old 03-15-2014, 09:52 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft x45 6.2L
Location: The South
Posts: 280
Quote:
Originally Posted by kentcunningham View Post
Thanks! I just bought a 2012 and I'm coming up to speed on these issues. Mine water-tested just fine, but I guess you never know.
I have come to realize that no matter what year you have the screen are going to have problems. My 2012 has been great since the updates. I guess that the price you pay to have fancy electronics on a boat.
__________________
Reply With Quote
  #210  
Old 03-15-2014, 11:55 PM
FoggyNogginz's Avatar
FoggyNogginz FoggyNogginz is offline
TT Enthusiast
 
Join Date: Aug 2006
Boat: 1998 PS205, then a 2002 X9, and now a 2012 X14V
Location: Center Hill Lake & Old Hickory
Posts: 365
I really wish that I could find one without the electronics, personally. This is my largest fear moving forward. I went to electrical engineering school for four years, and I'm pretty firmly against computers in a marine environment. Getting an all analog dash with mechanical switches seems to be tough to do these days though.

Great to hear that yours is working well now though. The new updates reportedly fix a lot of previous issues. I'm hoping that this is the case with mine.
__________________
----------------------------------

"KC"

Cmon...lemme just push one button...
- Red X14V on Center Hill & Old Hickory lakes in TN -
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:58 AM.