Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 10-10-2012, 09:44 PM
DeeeJay02's Avatar
DeeeJay02 DeeeJay02 is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 2006 XStar 8.1L Indmar, 2012 X25 6.0L Ilmor
Location: southwest
Posts: 147
2012 Touchscreen Issues!!!!!

Lets Hear Your Problems, Concerns and what we expect Mastercraft to do to make US the Consumer Happy with our Boats.....
__________________
Current Boat- 2012 X-25


Past Boats-
2006 XStar
2004 Eliminator 28' Daytona
2000 Eliminator 22' Daytona
Reply With Quote
  #2  
Old 10-10-2012, 10:05 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft X45 6.2L
Location: New Orleans, LA
Posts: 319
Quote:
Originally Posted by DeeeJay02 View Post
Lets Hear Your Problems, Concerns and what we expect Mastercraft to do to make US the Consumer Happy with our Boats.....
I have a 2012 X45 with the BIG touch screen along with the plug and play ballast. The touchscreen has been acting up lately, as in it will not allow me to control the radio at times and wont show some of the different screens. The plug and play ballast hasnt worked since day one. Something is always wrong with it. The actuator that switch the valve on the pumps from tank --> bag get stuck and we have already replaced the front and rear actuator. Now inorder to get the rear bags from bag --> tank you must push the actuator value an extra 1/4 inch to get it to set on the screen. Along with this the bags while emptying, will switch from 100% --> 0% instantly and the pumps shut off and wont allow me to drain the bags. It doesnt happen eveytime but just about every other time for some reason. If it does happen you have to flip the switch back and forth to drain the bag. Another problem that I have been having is that I can not run all three ballast pumps at the same time when in idle or else one with say N/C. However if I rev the engine some it will work just fine and pump all three a the same time.

Other than that, the boat is awesome and love it I just want a fix to this. We paid alot for this boat so I think MC should make it right by updating the screen or something. I will say I have the power tower and it has been great. I know people have been having problems with that but mine works great however I will be getting the upgrade this winter.
__________________
Reply With Quote
  #3  
Old 10-10-2012, 10:26 PM
DeeeJay02's Avatar
DeeeJay02 DeeeJay02 is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 2006 XStar 8.1L Indmar, 2012 X25 6.0L Ilmor
Location: southwest
Posts: 147
To start, I am on my 3rd Screen due to Hardware Failures.

Currently I am having these issues
-Perfect Pass does not work properly (befor and after adjustments)
-Perfect Pass will switch to RPM mode on its own
-Perfect Pass does not work at low speeds (under 12mph)
-Doesn't Auto-Fill or Empty when a Preset rider is selected or changed
-Launch Control is Intermitant (randomly on/off)
-Radio Control Screen goes Dead (unresponsive to touch)
-Depth Gauge flashes "Caution Low Depth" when in DEEP water (Depth alarm set at 2.5ft)
-Screen sometimes goes "White", and can't be fixed unless key is Turned off and back on.

I think that's everything, but I feel I'm forgetting something.....
__________________
Current Boat- 2012 X-25


Past Boats-
2006 XStar
2004 Eliminator 28' Daytona
2000 Eliminator 22' Daytona
Reply With Quote
  #4  
Old 10-10-2012, 10:39 PM
DeeeJay02's Avatar
DeeeJay02 DeeeJay02 is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 2006 XStar 8.1L Indmar, 2012 X25 6.0L Ilmor
Location: southwest
Posts: 147
I don't think this Update is the "Fix" and I feel Mastercraft should Replace our screens with that of the Murphy systems. I feel that if this is not done that our boat values will fall because nobody will want this one off problematic system.

If the problem is not rectified, I'm sure I/We could take legal action if necessary.....
__________________
Current Boat- 2012 X-25


Past Boats-
2006 XStar
2004 Eliminator 28' Daytona
2000 Eliminator 22' Daytona
Reply With Quote
  #5  
Old 10-10-2012, 10:54 PM
Ryan's Avatar
Ryan Ryan is online now
MC Maniac
 
Join Date: Jul 2004
Boat: 2007 X1
Location: Cincy
Posts: 3,034
Sorry to see there are issues with the hardware and software. It certainly helps me apppreciate my restored '93 PS190 just in time for my quarterly itch for a new boat. It's been a pretty regular pattern for the past 8 yeras...
__________________
Choose The Right 5mph>Wakeless Speed>32mph
Reply With Quote
  #6  
Old 10-11-2012, 12:17 AM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft X45 6.2L
Location: New Orleans, LA
Posts: 319
Quote:
Originally Posted by DeeeJay02 View Post
I don't think this Update is the "Fix" and I feel Mastercraft should Replace our screens with that of the Murphy systems. I feel that if this is not done that our boat values will fall because nobody will want this one off problematic system.

If the problem is not rectified, I'm sure I/We could take legal action if necessary.....
Couldnt agree more. i just want this fixed. it should be worth it to MC to make this right and get their reputation back on the right page.
__________________
Reply With Quote
  #7  
Old 10-11-2012, 09:15 AM
Double's Avatar
Double Double is offline
TT Enthusiast
 
Join Date: Jun 2012
Boat: Mastercraft, X30, 2012, 5.7
Location: Southeast
Posts: 126
I haven't had any of the issues others have except for the occasional slow change when I'm trying to switch screens, mainly to the radio and back. For the 2013 MC put a fixed remote for the radio which would be the easiest fix for my complaint. I just use the remote and leave the glove box open all the time
Reply With Quote
  #8  
Old 10-11-2012, 09:55 AM
TheWoons TheWoons is offline
MC Fanatic
 
Join Date: Feb 2012
Boat: 2014 X30. If you want a custom Soulcraft let me know :)
Location: Southwest
Posts: 670
Our 12' hasn't had any issues with the electronics including perfect pass. We have a power tower and we never had any issues with that either. It is however getting the updated hydraulics and braces. Our fuel level sensor stopped working and that's getting replaced and we had some other warranty stuff but the screen and functions have always been fine for us.
__________________
2014 X30
Reply With Quote
  #9  
Old 10-11-2012, 12:17 PM
AZX45OD's Avatar
AZX45OD AZX45OD is offline
TT Enthusiast
 
Join Date: Feb 2011
Boat: 2013 X-30 6.0L Red w/Silver Flake
Location: Southwest
Posts: 284
My '12 screen had some quirky issues at first and then started having problems selecting rider profiles and loading them, etc. The dealer ordered a new one and replaced it and it has been fine ever since. However, I do not have the PnP ballast etc, which may invite further issues...
Reply With Quote
  #10  
Old 10-11-2012, 12:27 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
Perfect pass not working as it should.
User configuration of perfect pass is a joke
Cannot control tower camera from BIG (on screen buttons do nothing)
Ballast resets to empty when switching from P&P bags to tanks, forcoing the computer to think the tanks are empty and prevents the pumps from running more than 10 seconds. (Bad programming IMO)
Pain in the *** when ever we want to turn down the radio, we have to flip through a bunch of screens.
Outside air temp not working - If was not intended to work, why put in in?
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:51 AM.