Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 09-06-2005, 11:26 AM
tall_ andy's Avatar
tall_ andy tall_ andy is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 88' MC Prostar
Location: Central NJ
Posts: 160
88' Prostar Speedometer Issues

I have an 88' Prostar which has the brass tubes in the back of the boat between the Pitot and the speedometer. I have found out that it is common for the tubes to be an issue. Both of mine have the top and bottom comming off which means a really wet boat and no speedometer. I spoke to Skidim, but they do not have replacements any more. I've tried duct tape, even JB weld nothing seems to work.
Any ideas are appreciated

Thanks
__________________
"I don't wanna grow up I'm a MasterCraft kid"
Reply With Quote
  #2  
Old 09-06-2005, 12:52 PM
PeteS's Avatar
PeteS PeteS is offline
TT Enthusiast
 
Join Date: Aug 2004
Boat: 1988 Prostar 190 - 351 Indmar (1:1) / 365 Hours
Location: Detroit
Posts: 399
Quote:
Originally Posted by tall_ andy
I have an 88' Prostar which has the brass tubes in the back of the boat between the Pitot and the speedometer. I have found out that it is common for the tubes to be an issue. Both of mine have the top and bottom comming off which means a really wet boat and no speedometer. I spoke to Skidim, but they do not have replacements any more. I've tried duct tape, even JB weld nothing seems to work.
Any ideas are appreciated

Thanks
There are a couple options, Andy. First, check with a few dealers in the area, not only MC, but Nautique and Malibu as well. Other older boats used this style of ballast resovoir for the Air Guide speedo, and you can sometimes find them in spare parts departments.

Secondly, you can take your damaged ballast to any radiator shop and they can repair it. Just let them know what you want done, and they'll fix you up. Hopefully that helps, and if not, you could always install in a paddle wheel based system, or Perfect Pass and eliminate the mechanical speedo's all together.
__________________
1988 Prostar 190 - 351 Indmar (1:1) / PerfectPass Digital Pro 6.5n, 13 x 12 Acme 3-Blade
Reply With Quote
  #3  
Old 09-06-2005, 01:12 PM
tall_ andy's Avatar
tall_ andy tall_ andy is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 88' MC Prostar
Location: Central NJ
Posts: 160
Pete,
I have perfect pass so that is what I use primarily, but it is nice to have the speedo working also. I will try a radiator shop
Thanks


Andy
__________________
"I don't wanna grow up I'm a MasterCraft kid"
Reply With Quote
  #4  
Old 09-06-2005, 03:52 PM
BriEOD's Avatar
BriEOD BriEOD is offline
MC Platinum
 
Join Date: Jul 2004
Boat: 2000 MasterCraft ProStar 205 DD
Location: Severn River, MD
Posts: 9,027
I had the bottom come off of one of mine and I used fast set epoxy. It works like a champ now.

Also, I've seen JimN say that you can solder these as well. I've never tried it, but I believe Jim.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:31 PM.