Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Thread Tools Display Modes
Old 05-21-2016, 07:03 AM
Mattymillz12 Mattymillz12 is offline
TT Enthusiast
Join Date: May 2016
Boat: 2005 Mastercraft XStar
Location: Northeast
Posts: 108
2005 Mastercraft Engine problems

So, I just recently bought a 2005 Mastercraft X star with the 6.0 Cadillac engine. The boat is gorgeous and runs great 90% of the time. On occasion the boat will decrease in speed and almost want to come to an idle. All gauges seem to be good with the exception of a ballast gauge not reading correctly, but I'm curious if anyone has had a similar issue with the engine? The boat starts and idles fine, but doesn't want to hold speed (large fluctuations) randomly when running. Any advice is awesome!

Sent from my iPhone using Tapatalk
Reply With Quote
Old 05-21-2016, 10:28 AM
pondo pondo is offline
TT Regular
Join Date: Jun 2015
Boat: 2005 Mastercraft X-2
Location: VA
Posts: 72
What RPMs do you see the problem typically?
Reply With Quote
Old 05-21-2016, 11:08 AM
lda6339 lda6339 is offline
MC Devotee
Join Date: May 2016
Boat: 2016 Mastercraft X-30 6.0L
Location: Dallas Texas
Posts: 1,361
Admin- duplicate thread
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -4. The time now is 04:07 PM.