Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 09-15-2012, 11:48 PM
woodrowskis woodrowskis is offline
TT Regular
 
Join Date: Jan 2011
Boat: 2002 Prostar 197 6.0 L
Location: South
Posts: 70
Ticking noise in exhaust 2010 X14v

Noise in exhaust. Can feel it in the left bank in the muffler and the flex hose. Did not hold the SS tubing to feel due to temperature. Has anyone had catalyst come loose or baffle loose in the muffler?

Can a bad plug possibly cause a sound like this? however I do not feel this in the exhaust manifold.
Reply With Quote
  #2  
Old 09-18-2012, 12:50 PM
JDK JDK is offline
TT Enthusiast
 
Join Date: Apr 2005
Boat: PS 205
Location: Saskatoon, Sask.
Posts: 460
Could this noise be coming from the bell housing
Whenever I've heard (or seen) a noise described as 'ticking' in a boat, it's been the flex plate.
Reply With Quote
  #3  
Old 09-18-2012, 03:12 PM
mastercraft210's Avatar
mastercraft210 mastercraft210 is offline
TT Regular
 
Join Date: Aug 2008
Boat: mx x star 01
Location: midwest
Posts: 44
Change the silence master (Muffler)
There is a loose plate inside.It will not damage anything but it is a irritating sound.
There where some in 2010 wich needs to be replaced .
Reply With Quote
Reply

Tags
exhaust, ticking noise

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:58 AM.