Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Towers

Reply
 
Thread Tools Display Modes
  #1  
Old 09-07-2012, 10:19 PM
js9467's Avatar
js9467 js9467 is offline
TT Newbie
 
Join Date: Jun 2012
Boat: 87 tristar
Location: Southeast
Posts: 27
Tristar Tower

I installed a Indy Liquid Pro tower this year. It looks good, the problem is that it seems to keep loosening. Originally, I installed it with just the large washers under the fiberglass. After quickly realizing that this wasn't going to work, I installed as much wood backing glued with 3M 5500 (I think) as I could with the washers and nylon nuts.

I used blue lock tight on all bolts and torqued the heck out of them.

The thing keeps getting loose! There is no play forward and back but a good bit side to side.

Any suggestions??
Reply With Quote
  #2  
Old 09-08-2012, 09:06 AM
madcityskier's Avatar
madcityskier madcityskier is offline
MC Devotee
 
Join Date: Sep 2008
Boat: 85 Stars&Stripes, safe-t-top, trick realease, boom, flitepipe pylon
Location: madison, wi
Posts: 1,723
Nylock nuts, lock washers, lock tight, double nuts. All the usuals. Try all at once. If that doesn't do it, keep a couple wrenches in the boat and make it part of the pre launch routine.
__________________
I spent most of my money on booze, broads and boats. The rest I wasted. - Elmore Leonard
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:29 AM.