Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 08-13-2012, 08:53 PM
dguille dguille is offline
TT Regular
 
Join Date: Dec 2007
Boat: 96 Mastercraft Prostar 205
Location: South
Posts: 34
96 prostar w/lt1 alternator question

I need to know the original part number for the alternator in a 96 prostar with a LT-1. Mine went out and I'm not near the boat and I need to order a new one. Also I want to up the amps to compensate my stereo so can anyone recommend a place to order and model that will work the best?? Thanks!
Reply With Quote
  #2  
Old 08-14-2012, 04:44 PM
ricford's Avatar
ricford ricford is offline
MC Fanatic
 
Join Date: Feb 2011
Boat: 1996 Prostar190
Location: Muskoka, Canada
Posts: 538
I'd start with calling skidim.
Reply With Quote
  #3  
Old 08-14-2012, 10:47 PM
jakethebt's Avatar
jakethebt jakethebt is offline
MC Fanatic
 
Join Date: Jul 2005
Boat: '96 Prostar 205 LT-1
Location: Dayton, OH
Posts: 581
I think this is the direct replacement from skidim:

http://http://www.skidim.com/prodinfo.asp?number=ARC60055

I also have a '96 LT1 and thought my alt was going this summer. I searched on here and found two things I will share...

First... the ground wire on the back of the alternators corrode a lot. I went to see if my ground wire was corroded and I broke the ground wire off just trying to find it. I crimped a new end on the wire and presto... My alt was only running 10v to 11v at idle and would hit 12v to 13v when at speed.

Second... during my search on here, many recommended having the old alt rebuilt by a local shop. I check into it and found a local source that would rebuild it for a little under $100. When mine finally does go, I will rebuild. If you want the detials of new vs rebuild, search the site.

Your last question was about increased output. I have never seen a marine alt with increased output. You are lucky to find a direct repalcement, let alone a selection of outputs. Let us know what you find out on this one...
__________________
1996 Prostar 205 LT-1
Reply With Quote
  #4  
Old 08-15-2012, 12:26 PM
pram's Avatar
pram pram is offline
Moderator
 
Join Date: Mar 2005
Boat: 1995 Mastercraft Prostar 205
Location: Kelowna BC
Posts: 1,939
Send a message via MSN to pram
I am wondering if my alternator is not performing properly on my 95-lt1 also.

It only reads 12.5 - 12.8 volts on the PP gauge

Should it not be reading 13.8 - 14.2??

Now I do think that I am in need of a new battery, it took a substantial amount of charging to get the battery to hold a charge

But that shouldn't affect how much voltage the alternator is putting out should it?
__________________
I live in my own little world. But it's OK - They know me here

MONKEY FACE
Reply With Quote
  #5  
Old 08-15-2012, 01:32 PM
BrianM's Avatar
BrianM BrianM is offline
MC Maniac
 
Join Date: Jul 2004
Boat: 1988 Prostar 190
Location: Mandeville, LA
Posts: 4,963
Posted in wrong thread..... sorry
__________________


1997 Prostar 190, TBI 350, 1:1, OJ XMP 13 x 11.5, Stargazer, Hot Shower, Heated Drivers Seat, Reuben/Mountain Rock/Nite Navy


Reply With Quote
  #6  
Old 08-27-2012, 12:21 AM
CC2MC's Avatar
CC2MC CC2MC is offline
MC Devotee
 
Join Date: Aug 2012
Boat: 2003 Maristar 210 Predator
Location: Alabama
Posts: 1,095
Yes, a weak battery could make for some crazy things happening.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:09 AM.