Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 08-19-2012, 02:07 PM
bruno1111 bruno1111 is offline
TT Newbie
 
Join Date: Aug 2012
Boat: Mastercraft 2012 X35
Location: Canada
Posts: 2
Ballast Pumps Run Time and Engine Running Req't

Hi There, my first post. Great forum BTW. I have a 2012 X35. No major issues with the B.I.G. system other than it is finicky, to say the least. The two questions/comments I have are:

The timers on all three tanks run way too long, my sides are full at less than 50% and my center tank is full around 60%. Anyone else have this issue and is there a way to fix it?

Also, I was told by the dealer not to fill the tanks without the motor running and at 1,500 rpm! This seems a bit conservative to me, I have filled them all with the motor off, running a Tsunami pump and the stereo playing, and have not seen any problems. Certainly not required to run the motors when filling tanks on a Malibu.

Thanks in advance for your help.
Reply With Quote
  #2  
Old 08-22-2012, 02:18 PM
jjct1 jjct1 is offline
TT Regular
 
Join Date: May 2011
Boat: 2004 X-Star
Location: Seattle Area
Posts: 32
Quote:
Originally Posted by bruno1111 View Post
Hi There, my first post. Great forum BTW. I have a 2012 X35. No major issues with the B.I.G. system other than it is finicky, to say the least. The two questions/comments I have are:

The timers on all three tanks run way too long, my sides are full at less than 50% and my center tank is full around 60%. Anyone else have this issue and is there a way to fix it?

Also, I was told by the dealer not to fill the tanks without the motor running and at 1,500 rpm! This seems a bit conservative to me, I have filled them all with the motor off, running a Tsunami pump and the stereo playing, and have not seen any problems. Certainly not required to run the motors when filling tanks on a Malibu.

Thanks in advance for your help.
I had problems on my 04 X-Star filling the ballasts when not running the engine. The kgb tank would fill but not port or starboard at the same time.

See:
http://www.mastercraft.com/teamtalk/...ad.php?t=50151
Reply With Quote
  #3  
Old 08-23-2012, 04:29 PM
bruno1111 bruno1111 is offline
TT Newbie
 
Join Date: Aug 2012
Boat: Mastercraft 2012 X35
Location: Canada
Posts: 2
Thanks for the note, my issue is not that the tanks are not filling, they are just filling and emptying faster than the timers and there does not seem to be a method to adjust the timer. I think there used to be a method on some of the older B.IG. set ups, but I can't seem to find it on my system.
Reply With Quote
  #4  
Old 08-23-2012, 04:56 PM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,700
The engine rpm req is so the pumps operate to their full potential. Will the run without the rpm boost sure, but that extra powerboost from the engine output on the alternator will give you the maximum performance for the pumps.


It's very easy to notice of u listen to the actual pump motor in both cases with engine off/Idle and at 1500+ rpms
__________________
2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop.
Reply With Quote
  #5  
Old 08-23-2012, 10:40 PM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,160
Having same issue. The problem is the 2012's don't have timers or tank level sensors, but determine levels solely based on pump rotations. There is no way to change this.

My 2012 X25 does same thing at any given time I have no idea how much water is in my ballast tanks...huge problem on a 100K boat.

Allegedly the new BIG software update coming out this fall for 2012 Medallion Systems will fix this system or make it work better. This is also my only major issue and a major annoyance.

Keep us posted on any fixes your dealer has.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:14 AM.