Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-25-2012, 12:22 PM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,808
Perfect Pass Wakeboard Pro wont engage

So randomly out of no where my PP stop engaging. It was working fine on monday, and then on tuesday we notice it would not engage.

Give throttle, and it passes the speed never beeps and the Rider name never changes color. What i did notice is when i go to slow down it acts like its engaging and a # sign flashes to the right of the rider name which is usually an arrow.

Any clue?

I reset to default and put my settings back in, still nothing...
Reply With Quote
  #2  
Old 08-25-2012, 11:08 PM
jfw432 jfw432 is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: other
Location: Lizella
Posts: 113
PP has a pretty good tech support.

Did you confirm that your GPS had a signal and check all the wire connections at the computer?
Reply With Quote
  #3  
Old 08-26-2012, 12:54 AM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,534
I started to have same issue, it then went to sometimes working and sometimes not. PP ended up replacing my master module as it was under warranty. Fixed the issue I diid try and troubleshoot it with them first. As mentioned they are a great company for customer service.
__________________
2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop.
Reply With Quote
  #4  
Old 08-27-2012, 12:34 PM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,808
jsut got a large document with some tests to run and then they said to call them back.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:59 AM.